aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2019-06-25 23:32:20 +0800
committerPetr Štetiar <ynezz@true.cz>2019-06-26 07:41:54 +0200
commit3f68cffd276df5b164ea0c7ecafb8fa062aa7a41 (patch)
tree60c051af709d722a3600783dc3777a39c72c7249 /target
parent110daa16e44bb53941a18396ab6a7d9fdd1fa362 (diff)
downloadupstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.tar.gz
upstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.tar.bz2
upstream-3f68cffd276df5b164ea0c7ecafb8fa062aa7a41.zip
ramips: add support for TOTOLINK A7000R
Specifications: - SoC: MT7621AT - RAM: 128MB - Flash: 16M SPI NOR - Ethernet: 5x GE ports - WiFi: 2.4G: MT7615N 5G: MT7615N Flash instruction: Upload generated sysupgrade firmware through factory web interface. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/dts/TOTOLINK-A7000R.dts123
-rw-r--r--target/linux/ramips/image/mt7621.mk9
3 files changed, 133 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index ffd1689263..02ef30cade 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -125,6 +125,7 @@ ramips_setup_interfaces()
sap-g3200u3|\
sk-wb8|\
telco-electronics,x1|\
+ totolink,a7000r|\
totolink,lr1200|\
unielec,u7621-06-256m-16m|\
unielec,u7621-06-512m-64m|\
diff --git a/target/linux/ramips/dts/TOTOLINK-A7000R.dts b/target/linux/ramips/dts/TOTOLINK-A7000R.dts
new file mode 100644
index 0000000000..4791862a6f
--- /dev/null
+++ b/target/linux/ramips/dts/TOTOLINK-A7000R.dts
@@ -0,0 +1,123 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "totolink,a7000r", "mediatek,mt7621-soc";
+ model = "TOTOLINK A7000R";
+
+ aliases {
+ led-boot = &led_sys;
+ led-failsafe = &led_sys;
+ led-running = &led_sys;
+ led-upgrade = &led_sys;
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x8000000>;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_sys: sys {
+ label = "a7000r:blue:sys";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c1e445f84c..dce24308b8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -235,6 +235,15 @@ define Device/k2p
endef
TARGET_DEVICES += k2p
+define Device/totolink_a7000r
+ DTS := TOTOLINK-A7000R
+ IMAGE_SIZE := 16064k
+ UIMAGE_NAME := C8340R1C-9999
+ DEVICE_TITLE := TOTOLINK A7000R
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += totolink_a7000r
+
define Device/xiaomi_mir3p
DTS := MIR3P
BLOCKSIZE := 128k