aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRichard Fröhning <misanthropos@gmx.de>2020-08-17 13:14:39 +0200
committerDavid Bauer <mail@david-bauer.net>2020-10-20 03:01:13 +0200
commit33b76d66d1afa9d888f32587b18d78a930593ca5 (patch)
tree4ddf27dc84b5c25922921d38865e570519f86383 /target
parent21cf17bb4ce5cb0cacb15d3659a544c215590001 (diff)
downloadupstream-33b76d66d1afa9d888f32587b18d78a930593ca5.tar.gz
upstream-33b76d66d1afa9d888f32587b18d78a930593ca5.tar.bz2
upstream-33b76d66d1afa9d888f32587b18d78a930593ca5.zip
ramips: add support for TP-Link RE200 v4
TP-Link RE200 v4 is a wireless range extender with Ethernet and 2.4G and 5G WiFi with internal antennas. It's based on MediaTek MT7628AN+MT7610EN like the v2/v3. Specifications -------------- - MediaTek MT7628AN (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz and 1T1R 5 GHz - 1x 10/100 Mbps Ethernet - 8x LED (GPIO-controlled), 2x button - UART connection holes on PCB (57600 8n1) There are 2.4G and 5G LEDs in red and green which are controlled separately. MAC addresses ------------- The MAC address assignment matches stock firmware, i.e.: LAN : *:8E 2.4G: *:8D 5G : *:8C MAC address assignment has been done according to the RE200 v2. The label MAC address matches the OpenWrt ethernet address. Installation ------------ Web Interface ------------- It is possible to upgrade to OpenWrt via the web interface. Simply flash the -factory.bin from OEM. In contrast to a stock firmware, this will not overwrite U-Boot. Recovery -------- Unfortunately, this devices does not offer a recovery mode or a tftp installation method. If the web interface upgrade fails, you have to open your device and attach serial console. Instructions for serial console and recovery may be checked out in commit 6d6f36ae787c ("ramips: add support for TP-Link RE200 v2") or on the device's Wiki page. Signed-off-by: Richard Fröhning <misanthropos@gmx.de> [removed empty line, fix commit message formatting] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts8
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network1
4 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts b/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts
new file mode 100644
index 0000000000..83f1f3acca
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_tplink_re200-v4.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_tplink_re200.dtsi"
+
+/ {
+ compatible = "tplink,re200-v4", "mediatek,mt7628an-soc";
+ model = "TP-Link RE200 v4";
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 326dcd82bb..6327c95bb0 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -413,6 +413,16 @@ define Device/tplink_re200-v3
endef
TARGET_DEVICES += tplink_re200-v3
+define Device/tplink_re200-v4
+ $(Device/tplink-safeloader)
+ IMAGE_SIZE := 7808k
+ DEVICE_MODEL := RE200
+ DEVICE_VARIANT := v4
+ DEVICE_PACKAGES := kmod-mt76x0e
+ TPLINK_BOARD_ID := RE200-V4
+endef
+TARGET_DEVICES += tplink_re200-v4
+
define Device/tplink_re220-v2
$(Device/tplink-safeloader)
IMAGE_SIZE := 7808k
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
index c26d6436e9..e1c3454237 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
@@ -62,6 +62,7 @@ tplink,archer-c50-v4)
;;
tplink,re200-v2|\
tplink,re200-v3|\
+tplink,re200-v4|\
tplink,re220-v2|\
tplink,tl-mr3020-v3|\
tplink,tl-wa801nd-v5)
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index f1687c7108..2cda818b2a 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -20,6 +20,7 @@ ramips_setup_interfaces()
tama,w06|\
tplink,re200-v2|\
tplink,re200-v3|\
+ tplink,re200-v4|\
tplink,re220-v2|\
tplink,re305-v1|\
tplink,tl-mr3020-v3|\