aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-07-12 13:38:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-07-12 13:38:40 +0000
commit33220828dc3f7a41ae066b47375929dad6deb914 (patch)
tree45c47deea9e5686edce2b74bec6bfb58a116fd4d /target
parent372945185d06e388dd834e3fcd85c7f0c1893899 (diff)
downloadupstream-33220828dc3f7a41ae066b47375929dad6deb914.tar.gz
upstream-33220828dc3f7a41ae066b47375929dad6deb914.tar.bz2
upstream-33220828dc3f7a41ae066b47375929dad6deb914.zip
ar71xx: build firmware image for the TP-Link TL-WDR4310 v1.0
The hardware for TP-Link TL-WDR4300 v1.1 and TL-WDR4310 v1.0 is identical, but requires different firmware headers: TL-WDR4300: 00000040 43 00 00 01 00 00 00 01 00 00 00 00 76 fb 83 40 |C...........v..@| TL-WDR4310: 00000040 43 10 00 01 00 00 00 01 00 00 00 00 38 2b 50 6c |C...........8+Pl| [juhosg: change commit message, use a different model name] Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de> SVN-Revision: 32683
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk2
-rw-r--r--target/linux/ar71xx/image/Makefile1
3 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 702fa7e546..8c83356ce1 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -126,6 +126,9 @@ tplink_board_detect() {
"430000"*)
model="TP-Link TL-WDR4300"
;;
+ "431000"*)
+ model="TP-Link TL-WDR4310"
+ ;;
*)
hwver=""
;;
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 23e6b96e2e..74355e83b8 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -95,7 +95,7 @@ $(eval $(call Profile,TLWA901))
define Profile/TLWDR4300
- NAME:=TP-LINK TL-WDR4300
+ NAME:=TP-LINK TL-WDR4300/ TL-WDR4310
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 6e2180ea8e..6c2581ddb5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -990,6 +990,7 @@ endef
tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
define Image/Build/Profile/TLWDR4300
$(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+ $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
endef
wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200