aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSven Eckelmann <sven@narfation.org>2020-11-23 13:41:34 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-19 15:39:36 +0100
commit31172e53f9d0971204e6fa7e3541c0695d99618a (patch)
tree986c99f72c02d94ddc9a614efaf3e3c903ccbec2 /target
parente06c9eec5dc8a3721df768ab952712cf015d4e6f (diff)
downloadupstream-31172e53f9d0971204e6fa7e3541c0695d99618a.tar.gz
upstream-31172e53f9d0971204e6fa7e3541c0695d99618a.tar.bz2
upstream-31172e53f9d0971204e6fa7e3541c0695d99618a.zip
ath79: Add support for OpenMesh MR900 v2
Device specifications: ====================== * Qualcomm/Atheros QCA9558 ver 1 rev 0 * 720/600/240 MHz (CPU/DDR/AHB) * 128 MB of RAM * 16 MB of SPI NOR flash - 2x 7 MB available; but one of the 7 MB regions is the recovery image * 3T3R 2.4 GHz Wi-Fi * 3T3R 5 GHz Wi-Fi * 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power) * 1x GPIO-button (reset) * external h/w watchdog (enabled by default)) * TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX) * 1x ethernet - AR8035 ethernet PHY (RGMII) - 10/100/1000 Mbps Ethernet - 802.3af POE - used as LAN interface * 12-24V 1A DC * internal antennas Flashing instructions: ====================== Various methods can be used to install the actual image on the flash. Two easy ones are: ap51-flash ---------- The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be used to transfer the image to the u-boot when the device boots up. initramfs from TFTP ------------------- The serial console must be used to access the u-boot shell during bootup. It can then be used to first boot up the initramfs image from a TFTP server (here with the IP 192.168.1.21): setenv serverip 192.168.1.21 setenv ipaddr 192.168.1.1 tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr The actual sysupgrade image can then be transferred (on the LAN port) to the device via scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/ On the device, the sysupgrade must then be started using sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin Signed-off-by: Sven Eckelmann <sven@narfation.org> [rebase, add LED migration] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts8
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/generic/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration3
-rw-r--r--target/linux/ath79/generic/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ath79/image/generic.mk7
6 files changed, 21 insertions, 2 deletions
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts b/target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts
new file mode 100644
index 0000000000..008caae2ec
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr900.dtsi"
+
+/ {
+ compatible = "openmesh,mr900-v2", "qca,qca9558";
+ model = "OpenMesh MR900 v2";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 034c2d2933..8fba9bc0e7 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -158,7 +158,8 @@ telco,t1)
comfast,cf-wr752ac-v1|\
engenius,eap300-v2|\
enterasys,ws-ap3705i|\
-openmesh,mr900-v1)
+openmesh,mr900-v1|\
+openmesh,mr900-v2)
ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
;;
compex,wpj344-16m|\
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 8a15d2ad55..76bbd92c21 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -49,6 +49,7 @@ ath79_setup_interfaces()
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
+ openmesh,mr900-v2|\
pcs,cap324|\
pisen,ts-d084|\
pisen,wmb001n|\
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
index ad14eb2941..453bf3b911 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
@@ -23,7 +23,8 @@ openmesh,mr600-v1)
openmesh,mr600-v2)
migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
;;
-openmesh,mr900-v1)
+openmesh,mr900-v1|\
+openmesh,mr900-v2)
migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
;;
pcs,cap324)
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 40197cfaa8..76512758b6 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -53,6 +53,7 @@ platform_do_upgrade() {
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
+ openmesh,mr900-v2|\
openmesh,om2p-v2|\
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 9d6fd398d9..fec7f06215 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1572,6 +1572,13 @@ define Device/openmesh_mr900-v1
endef
TARGET_DEVICES += openmesh_mr900-v1
+define Device/openmesh_mr900-v2
+ $(Device/openmesh_mr900-common)
+ DEVICE_VARIANT := v2
+ SUPPORTED_DEVICES += mr900v2
+endef
+TARGET_DEVICES += openmesh_mr900-v2
+
define Device/openmesh_om2p-common
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools