aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-11-03 02:45:45 +0100
committerAlexander Couzens <lynxis@fe80.eu>2017-11-06 00:09:18 +0100
commit2e1f73a79f90faef133ece10f41178a894fc762e (patch)
tree9cec561bb369b8e3754bcb48dbbaf82521b493bf /target
parent1c68fd6d757812c6a36f3a6a1175ff0903381989 (diff)
downloadupstream-2e1f73a79f90faef133ece10f41178a894fc762e.tar.gz
upstream-2e1f73a79f90faef133ece10f41178a894fc762e.tar.bz2
upstream-2e1f73a79f90faef133ece10f41178a894fc762e.zip
mt7620: image.mk: make elecom-header reproducible
elecom-header adds a timestamp dependency. Replace the timestamps with SOURCE_DATE_EPOCH [0] variable. [0] https://reproducible-builds.org/specs/source-date-epoch/ Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7620.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 2f3f59e4c6..796cc619a3 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -10,7 +10,9 @@ define Build/elecom-header
mkhash md5 $(KDIR)/v_0.0.0.bin && \
echo 458 \
) | mkhash md5 > $(KDIR)/v_0.0.0.md5
- $(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
+ $(STAGING_DIR_HOST)/bin/tar -c \
+ $(if $(SOURCE_DATE_EPOCH),--mtime=@$(SOURCE_DATE_EPOCH)) \
+ -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
define Build/zyimage