aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Thomson <git@johnthomson.fastmail.com.au>2020-08-10 19:40:55 +1000
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-13 02:12:12 +0200
commit2d9db93397f3120591bab0cf89347eec55c168f3 (patch)
treee9eb8a6c8d098ec4c9cbadba749b8cb5dba4c4da /target
parent87e92d50e577851743663763bc749fe18aa294c7 (diff)
downloadupstream-2d9db93397f3120591bab0cf89347eec55c168f3.tar.gz
upstream-2d9db93397f3120591bab0cf89347eec55c168f3.tar.bz2
upstream-2d9db93397f3120591bab0cf89347eec55c168f3.zip
ramips: use gpio-export for Mikrotik RouterBOARD 750Gr3 beeper
This beeper hardware requires a PWM driver for frequency selection. Since the GPIO driver does not provide that, revert the beeper support to a simple gpio-export. This effectively reverts the corresponding changes from 6ba58b7b020c ("ramips: cleanup the RB750Gr3 support") Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au> [commit title/message facelift] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts12
-rw-r--r--target/linux/ramips/image/mt7621.mk2
2 files changed, 8 insertions, 6 deletions
diff --git a/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
index a516f337cc..f767599e98 100644
--- a/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
+++ b/target/linux/ramips/dts/mt7621_mikrotik_routerboard-750gr3.dts
@@ -52,15 +52,17 @@
};
};
- beeper {
- compatible = "gpio-beeper";
- gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
- };
-
gpio_export {
compatible = "gpio-export";
#size-cells = <0>;
+ buzzer {
+ /* Beeper requires PWM for frequency selection */
+ gpio-export,name = "buzzer";
+ gpio-export,output = <0>;
+ gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+ };
+
usb_power {
gpio-export,name = "usb_power";
gpio-export,output = <1>;
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c922303c54..16b74c7b3e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -703,7 +703,7 @@ endef
define Device/mikrotik_routerboard-750gr3
$(Device/MikroTik)
DEVICE_MODEL := RouterBOARD 750Gr3
- DEVICE_PACKAGES += kmod-gpio-beeper -wpad-basic
+ DEVICE_PACKAGES += -wpad-basic
SUPPORTED_DEVICES += mikrotik,rb750gr3
endef
TARGET_DEVICES += mikrotik_routerboard-750gr3