aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2021-02-16 19:35:01 +0100
committerMathias Kresin <dev@kresin.me>2021-03-01 00:23:30 +0100
commit2638c9801f92fc77aa07a8eb426f6bd8dbc1cc42 (patch)
treea7f404458e83e38c02c07df67cb765d5725d1568 /target
parentadc3a75d48ca13a61d849ff03e8e831add10d156 (diff)
downloadupstream-2638c9801f92fc77aa07a8eb426f6bd8dbc1cc42.tar.gz
upstream-2638c9801f92fc77aa07a8eb426f6bd8dbc1cc42.tar.bz2
upstream-2638c9801f92fc77aa07a8eb426f6bd8dbc1cc42.zip
lantiq: set maximum kernel size
These boards have a fixed size kernel partition but do not limit the kernel size during image building. Disable image building for both boards as well, since the kernel of the last release as well as master are to big to fit into the 2 MByte kernel partition. Signed-off-by: Mathias Kresin <dev@kresin.me> (cherry picked from commit 23dd7867347ab4fd88592d0bfec1ce5a959c09f3)
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/image/ar9.mk2
-rw-r--r--target/linux/lantiq/image/danube.mk2
2 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/lantiq/image/ar9.mk b/target/linux/lantiq/image/ar9.mk
index ad061b2776..a973c90beb 100644
--- a/target/linux/lantiq/image/ar9.mk
+++ b/target/linux/lantiq/image/ar9.mk
@@ -34,6 +34,7 @@ define Device/bt_homehub-v3a
DEVICE_VARIANT := Type A
BOARD_NAME := BTHOMEHUBV3A
SOC := ar9
+ KERNEL_SIZE := 2048k
DEVICE_PACKAGES := kmod-usb-dwc2 \
kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
kmod-ltq-adsl-ar9-fw-a kmod-ltq-atm-ar9 \
@@ -42,6 +43,7 @@ define Device/bt_homehub-v3a
kmod-ath9k kmod-owl-loader wpad-basic-wolfssl \
uboot-envtools
SUPPORTED_DEVICES += BTHOMEHUBV3A
+ DEFAULT := n
endef
TARGET_DEVICES += bt_homehub-v3a
diff --git a/target/linux/lantiq/image/danube.mk b/target/linux/lantiq/image/danube.mk
index ea22081d65..73ec27222a 100644
--- a/target/linux/lantiq/image/danube.mk
+++ b/target/linux/lantiq/image/danube.mk
@@ -188,6 +188,7 @@ define Device/bt_homehub-v2b
DEVICE_VARIANT := Type B
BOARD_NAME := BTHOMEHUBV2B
SOC := danube
+ KERNEL_SIZE := 2048k
DEVICE_PACKAGES := kmod-usb-dwc2 \
kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
kmod-ltq-adsl-danube-fw-a kmod-ltq-atm-danube \
@@ -195,6 +196,7 @@ define Device/bt_homehub-v2b
ltq-adsl-app ppp-mod-pppoa \
kmod-ath9k kmod-owl-loader wpad-basic-wolfssl
SUPPORTED_DEVICES += BTHOMEHUBV2B
+ DEFAULT := n
endef
TARGET_DEVICES += bt_homehub-v2b