aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2010-12-22 17:19:36 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2010-12-22 17:19:36 +0000
commit22d8dcbf447f54b1a4ff0365c8a5f53736984cf0 (patch)
tree44bc4628235a7deaf2f4a1aefa4d1bb5b828e36d /target
parent72ca63488b7a1efd184235509176de9526106cde (diff)
downloadupstream-22d8dcbf447f54b1a4ff0365c8a5f53736984cf0.tar.gz
upstream-22d8dcbf447f54b1a4ff0365c8a5f53736984cf0.tar.bz2
upstream-22d8dcbf447f54b1a4ff0365c8a5f53736984cf0.zip
adm5120: make patches apply again and refresh them
SVN-Revision: 24800
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/patches-2.6.32/007-adm5120_pci.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch12
-rw-r--r--target/linux/adm5120/patches-2.6.34/001-adm5120.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch12
-rw-r--r--target/linux/adm5120/patches-2.6.34/101-cfi_fixup_macronix_bootloc.patch8
-rw-r--r--target/linux/adm5120/patches-2.6.34/103-mtd_trxsplit.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.35/001-adm5120.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.35/007-adm5120_pci.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch12
-rw-r--r--target/linux/adm5120/patches-2.6.35/101-cfi_fixup_macronix_bootloc.patch12
-rw-r--r--target/linux/adm5120/patches-2.6.35/102-jedec_pmc_39lvxxx_chips.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch6
-rw-r--r--target/linux/adm5120/patches-2.6.35/203-gpio_leds_brightness.patch2
-rw-r--r--target/linux/adm5120/patches-2.6.35/310-adm5120_wdt.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.36/001-adm5120.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.36/003-adm5120_switch.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch12
-rw-r--r--target/linux/adm5120/patches-2.6.36/102-jedec_pmc_39lvxxx_chips.patch4
-rw-r--r--target/linux/adm5120/patches-2.6.37/009-adm5120_leds_switch_trigger.patch12
21 files changed, 63 insertions, 63 deletions
diff --git a/target/linux/adm5120/patches-2.6.32/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.32/007-adm5120_pci.patch
index 91bd79d761..b06d7947ce 100644
--- a/target/linux/adm5120/patches-2.6.32/007-adm5120_pci.patch
+++ b/target/linux/adm5120/patches-2.6.32/007-adm5120_pci.patch
@@ -10,7 +10,7 @@
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -1748,6 +1748,9 @@
+@@ -1752,6 +1752,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
index 272fb8f19c..2f6eaf06e3 100644
--- a/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.32/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -315,4 +315,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -322,4 +322,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -42,3 +42,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -43,3 +43,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
diff --git a/target/linux/adm5120/patches-2.6.34/001-adm5120.patch b/target/linux/adm5120/patches-2.6.34/001-adm5120.patch
index c6eec1e23f..c99399cb13 100644
--- a/target/linux/adm5120/patches-2.6.34/001-adm5120.patch
+++ b/target/linux/adm5120/patches-2.6.34/001-adm5120.patch
@@ -22,7 +22,7 @@
config MACH_ALCHEMY
bool "Alchemy processor based machines"
select SYS_SUPPORTS_ZBOOT
-@@ -681,6 +696,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
+@@ -683,6 +698,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
endchoice
@@ -32,7 +32,7 @@
source "arch/mips/jazz/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -214,6 +214,23 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
+@@ -227,6 +227,23 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#
diff --git a/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
index b06d7947ce..12d0f4aa9e 100644
--- a/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
+++ b/target/linux/adm5120/patches-2.6.34/007-adm5120_pci.patch
@@ -10,7 +10,7 @@
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -1752,6 +1752,9 @@
+@@ -1753,6 +1753,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch
index 0258fa4fbe..777476f3ef 100644
--- a/target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.34/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -365,4 +365,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -372,4 +372,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -49,3 +49,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
diff --git a/target/linux/adm5120/patches-2.6.34/101-cfi_fixup_macronix_bootloc.patch b/target/linux/adm5120/patches-2.6.34/101-cfi_fixup_macronix_bootloc.patch
index 43459328a4..5ecf166505 100644
--- a/target/linux/adm5120/patches-2.6.34/101-cfi_fixup_macronix_bootloc.patch
+++ b/target/linux/adm5120/patches-2.6.34/101-cfi_fixup_macronix_bootloc.patch
@@ -1,8 +1,8 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -53,6 +53,12 @@
+@@ -52,6 +52,12 @@
+ #define SST49LF008A 0x005a
#define AT49BV6416 0x00d6
- #define MANUFACTURER_SAMSUNG 0x00ec
+/* Macronix */
+#define MX29LV160B 0x2249 /* MX29LV160 Bottom-boot chip */
@@ -13,7 +13,7 @@
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
static int cfi_amdstd_write_buffers(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -283,6 +289,41 @@ static void fixup_s29gl032n_sectors(stru
+@@ -282,6 +288,41 @@ static void fixup_s29gl032n_sectors(stru
}
}
@@ -55,7 +55,7 @@
static struct cfi_fixup cfi_fixup_table[] = {
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
#ifdef AMD_BOOTLOC_BUG
-@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
+@@ -318,6 +359,9 @@ static struct cfi_fixup fixup_table[] =
*/
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },
diff --git a/target/linux/adm5120/patches-2.6.34/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.34/103-mtd_trxsplit.patch
index 69f1035505..ec4f6c5a40 100644
--- a/target/linux/adm5120/patches-2.6.34/103-mtd_trxsplit.patch
+++ b/target/linux/adm5120/patches-2.6.34/103-mtd_trxsplit.patch
@@ -14,7 +14,7 @@
depends on MTD_PARTITIONS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
diff --git a/target/linux/adm5120/patches-2.6.35/001-adm5120.patch b/target/linux/adm5120/patches-2.6.35/001-adm5120.patch
index c6eec1e23f..c99399cb13 100644
--- a/target/linux/adm5120/patches-2.6.35/001-adm5120.patch
+++ b/target/linux/adm5120/patches-2.6.35/001-adm5120.patch
@@ -22,7 +22,7 @@
config MACH_ALCHEMY
bool "Alchemy processor based machines"
select SYS_SUPPORTS_ZBOOT
-@@ -681,6 +696,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
+@@ -683,6 +698,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
endchoice
@@ -32,7 +32,7 @@
source "arch/mips/jazz/Kconfig"
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -214,6 +214,23 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
+@@ -227,6 +227,23 @@ cflags-$(CONFIG_MACH_JAZZ) += -I$(srctre
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
#
diff --git a/target/linux/adm5120/patches-2.6.35/007-adm5120_pci.patch b/target/linux/adm5120/patches-2.6.35/007-adm5120_pci.patch
index b06d7947ce..fa8dd44e8a 100644
--- a/target/linux/adm5120/patches-2.6.35/007-adm5120_pci.patch
+++ b/target/linux/adm5120/patches-2.6.35/007-adm5120_pci.patch
@@ -10,7 +10,7 @@
obj-$(CONFIG_CPU_CAVIUM_OCTEON) += msi-octeon.o
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -1752,6 +1752,9 @@
+@@ -1756,6 +1756,9 @@
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
diff --git a/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
index 0258fa4fbe..fb65ef3f86 100644
--- a/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.35/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -365,4 +365,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -389,4 +389,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -48,3 +48,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
diff --git a/target/linux/adm5120/patches-2.6.35/101-cfi_fixup_macronix_bootloc.patch b/target/linux/adm5120/patches-2.6.35/101-cfi_fixup_macronix_bootloc.patch
index ec7505c58d..31217c4721 100644
--- a/target/linux/adm5120/patches-2.6.35/101-cfi_fixup_macronix_bootloc.patch
+++ b/target/linux/adm5120/patches-2.6.35/101-cfi_fixup_macronix_bootloc.patch
@@ -1,8 +1,8 @@
--- a/drivers/mtd/chips/cfi_cmdset_0002.c
+++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -53,6 +53,12 @@
+@@ -49,6 +49,12 @@
+ #define SST49LF008A 0x005a
#define AT49BV6416 0x00d6
- #define MANUFACTURER_SAMSUNG 0x00ec
+/* Macronix */
+#define MX29LV160B 0x2249 /* MX29LV160 Bottom-boot chip */
@@ -13,9 +13,9 @@
static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
static int cfi_amdstd_write_buffers(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -283,6 +289,41 @@ static void fixup_s29gl032n_sectors(stru
- }
- }
+@@ -329,6 +335,41 @@ static struct cfi_fixup cfi_nopri_fixup_
+ { 0, 0, NULL, NULL }
+ };
+#ifdef CONFIG_MTD_CFI_FIXUP_MACRONIX_BOOTLOC
+/*
@@ -55,7 +55,7 @@
static struct cfi_fixup cfi_fixup_table[] = {
{ CFI_MFR_ATMEL, CFI_ID_ANY, fixup_convert_atmel_pri, NULL },
#ifdef AMD_BOOTLOC_BUG
-@@ -319,6 +360,9 @@ static struct cfi_fixup fixup_table[] =
+@@ -365,6 +406,9 @@ static struct cfi_fixup fixup_table[] =
*/
{ CFI_MFR_ANY, CFI_ID_ANY, fixup_use_erase_chip, NULL },
{ CFI_MFR_ATMEL, AT49BV6416, fixup_use_atmel_lock, NULL },
diff --git a/target/linux/adm5120/patches-2.6.35/102-jedec_pmc_39lvxxx_chips.patch b/target/linux/adm5120/patches-2.6.35/102-jedec_pmc_39lvxxx_chips.patch
index 1e5d23a233..626cd85f20 100644
--- a/target/linux/adm5120/patches-2.6.35/102-jedec_pmc_39lvxxx_chips.patch
+++ b/target/linux/adm5120/patches-2.6.35/102-jedec_pmc_39lvxxx_chips.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/jedec_probe.c
+++ b/drivers/mtd/chips/jedec_probe.c
-@@ -133,6 +133,10 @@
+@@ -116,6 +116,10 @@
#define UPD29F064115 0x221C
/* PMC */
@@ -11,7 +11,7 @@
#define PM49FL002 0x006D
#define PM49FL004 0x006E
#define PM49FL008 0x006A
-@@ -1275,6 +1279,54 @@ static const struct amd_flash_info jedec
+@@ -1273,6 +1277,54 @@ static const struct amd_flash_info jedec
ERASEINFO(0x02000,2),
ERASEINFO(0x04000,1),
}
diff --git a/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch b/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
index 69f1035505..ec4f6c5a40 100644
--- a/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
+++ b/target/linux/adm5120/patches-2.6.35/103-mtd_trxsplit.patch
@@ -14,7 +14,7 @@
depends on MTD_PARTITIONS
--- a/drivers/mtd/Makefile
+++ b/drivers/mtd/Makefile
-@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o mtdbdi.
+@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
diff --git a/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
index 5bb36432ab..9b486a7f9b 100644
--- a/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
+++ b/target/linux/adm5120/patches-2.6.35/120-rb153_cf_driver.patch
@@ -10,9 +10,9 @@
obj-$(CONFIG_PATA_ACPI) += pata_acpi.o
--- a/drivers/ata/Kconfig
+++ b/drivers/ata/Kconfig
-@@ -604,6 +604,15 @@ config PATA_RADISYS
-
- If unsure, say N.
+@@ -778,6 +778,15 @@ config PATA_QDI
+ help
+ Support for QDI 6500 and 6580 PATA controllers on VESA local bus.
+config PATA_RB153_CF
+ tristate "RouterBOARD 153 Compact Flash support"
diff --git a/target/linux/adm5120/patches-2.6.35/203-gpio_leds_brightness.patch b/target/linux/adm5120/patches-2.6.35/203-gpio_leds_brightness.patch
index 54c6468699..ac3c516353 100644
--- a/target/linux/adm5120/patches-2.6.35/203-gpio_leds_brightness.patch
+++ b/target/linux/adm5120/patches-2.6.35/203-gpio_leds_brightness.patch
@@ -1,6 +1,6 @@
--- a/drivers/leds/leds-gpio.c
+++ b/drivers/leds/leds-gpio.c
-@@ -45,13 +45,17 @@ static void gpio_led_set(struct led_clas
+@@ -52,13 +52,17 @@ static void gpio_led_set(struct led_clas
container_of(led_cdev, struct gpio_led_data, cdev);
int level;
diff --git a/target/linux/adm5120/patches-2.6.35/310-adm5120_wdt.patch b/target/linux/adm5120/patches-2.6.35/310-adm5120_wdt.patch
index 0c4e8e623c..bcc3230ac1 100644
--- a/target/linux/adm5120/patches-2.6.35/310-adm5120_wdt.patch
+++ b/target/linux/adm5120/patches-2.6.35/310-adm5120_wdt.patch
@@ -1,6 +1,6 @@
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -807,6 +807,18 @@ config RC32434_WDT
+@@ -825,6 +825,18 @@ config RC32434_WDT
To compile this driver as a module, choose M here: the
module will be called rc32434_wdt.
@@ -21,7 +21,7 @@
depends on SGI_HAS_INDYDOG
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -113,6 +113,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
+@@ -114,6 +114,7 @@ obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
diff --git a/target/linux/adm5120/patches-2.6.36/001-adm5120.patch b/target/linux/adm5120/patches-2.6.36/001-adm5120.patch
index 4f183c49e7..b96307742a 100644
--- a/target/linux/adm5120/patches-2.6.36/001-adm5120.patch
+++ b/target/linux/adm5120/patches-2.6.36/001-adm5120.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -25,6 +25,21 @@ choice
+@@ -26,6 +26,21 @@ choice
prompt "System type"
default SGI_IP22
@@ -22,7 +22,7 @@
config MIPS_ALCHEMY
bool "Alchemy processor based machines"
select 64BIT_PHYS_ADDR
-@@ -707,6 +722,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
+@@ -708,6 +723,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
endchoice
diff --git a/target/linux/adm5120/patches-2.6.36/003-adm5120_switch.patch b/target/linux/adm5120/patches-2.6.36/003-adm5120_switch.patch
index d8443ed5fd..fb5fb83127 100644
--- a/target/linux/adm5120/patches-2.6.36/003-adm5120_switch.patch
+++ b/target/linux/adm5120/patches-2.6.36/003-adm5120_switch.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/Kconfig
+++ b/drivers/net/Kconfig
-@@ -491,6 +491,10 @@ config MIPS_AU1X00_ENET
+@@ -614,6 +614,10 @@ config MIPS_AU1X00_ENET
If you have an Alchemy Semi AU1X00 based system
say Y. Otherwise, say N.
@@ -13,7 +13,7 @@
depends on PCI && SGI_IP27
--- a/drivers/net/Makefile
+++ b/drivers/net/Makefile
-@@ -212,6 +212,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
+@@ -213,6 +213,7 @@ obj-$(CONFIG_SC92031) += sc92031.o
# This is also a 82596 and should probably be merged
obj-$(CONFIG_LP486E) += lp486e.o
diff --git a/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
index a52dfac7a8..f8e550d9f8 100644
--- a/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.36/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -391,4 +391,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -398,4 +398,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
diff --git a/target/linux/adm5120/patches-2.6.36/102-jedec_pmc_39lvxxx_chips.patch b/target/linux/adm5120/patches-2.6.36/102-jedec_pmc_39lvxxx_chips.patch
index 00148fa602..626cd85f20 100644
--- a/target/linux/adm5120/patches-2.6.36/102-jedec_pmc_39lvxxx_chips.patch
+++ b/target/linux/adm5120/patches-2.6.36/102-jedec_pmc_39lvxxx_chips.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/chips/jedec_probe.c
+++ b/drivers/mtd/chips/jedec_probe.c
-@@ -115,6 +115,10 @@
+@@ -116,6 +116,10 @@
#define UPD29F064115 0x221C
/* PMC */
@@ -11,7 +11,7 @@
#define PM49FL002 0x006D
#define PM49FL004 0x006E
#define PM49FL008 0x006A
-@@ -1259,6 +1263,54 @@ static const struct amd_flash_info jedec
+@@ -1273,6 +1277,54 @@ static const struct amd_flash_info jedec
ERASEINFO(0x02000,2),
ERASEINFO(0x04000,1),
}
diff --git a/target/linux/adm5120/patches-2.6.37/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.37/009-adm5120_leds_switch_trigger.patch
index b13d48f556..2f6eaf06e3 100644
--- a/target/linux/adm5120/patches-2.6.37/009-adm5120_leds_switch_trigger.patch
+++ b/target/linux/adm5120/patches-2.6.37/009-adm5120_leds_switch_trigger.patch
@@ -1,8 +1,8 @@
--- a/drivers/leds/Kconfig
+++ b/drivers/leds/Kconfig
-@@ -400,4 +400,12 @@ config LEDS_TRIGGER_NETDEV
- This allows LEDs to be controlled by network device activity.
- If unsure, say Y.
+@@ -322,4 +322,12 @@ config LEDS_TRIGGER_USBDEV
+ This allows LEDs to be controlled by the presence/activity of
+ an USB device. If unsure, say N.
+config LEDS_TRIGGER_ADM5120_SWITCH
+ tristate "LED ADM5120 Switch Port Status Trigger"
@@ -15,8 +15,8 @@
endif # NEW_LEDS
--- a/drivers/leds/Makefile
+++ b/drivers/leds/Makefile
-@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledt
- obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
+@@ -43,3 +43,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) +=
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
- obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV) += ledtrig-usbdev.o
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o