aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-06 07:20:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-06 07:20:59 +0000
commit1e848b17ad73b8a6db44ee19cef2574bb9811e36 (patch)
tree9e28fe04ade759088f1bc14e90db158d70acca76 /target
parent84cd8a5ee054281fbc3b87fc38c5048e99283f08 (diff)
downloadupstream-1e848b17ad73b8a6db44ee19cef2574bb9811e36.tar.gz
upstream-1e848b17ad73b8a6db44ee19cef2574bb9811e36.tar.bz2
upstream-1e848b17ad73b8a6db44ee19cef2574bb9811e36.zip
ar71xx: add support for Redwave RW2458N
Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com> SVN-Revision: 29669
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-2.6.391
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/mach-rw2458n.c101
-rw-r--r--target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h1
-rw-r--r--target/linux/ar71xx/generic/profiles/redwave.mk17
-rw-r--r--target/linux/ar71xx/image/Makefile6
10 files changed, 143 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 3332a7f6e3..dcac49de5b 100755
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -91,6 +91,9 @@ get_status_led() {
routerstation | routerstation-pro)
status_led="ubnt:green:rf"
;;
+ rw2458n)
+ status_led="rw2458n:green:d3"
+ ;;
tew-632brp)
status_led="tew-632brp:green:status"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index cc0b0b4d32..7e8e25e3ac 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -238,6 +238,9 @@ ar71xx_board_detect() {
*"RouterStation Pro")
name="routerstation-pro"
;;
+ *RW2458N)
+ name="rw2458n"
+ ;;
*TEW-632BRP)
name="tew-632brp"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 14af3bfc36..fc864eb4eb 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -105,6 +105,7 @@ platform_check_image() {
bullet-m | \
nanostation-m | \
rocket-m | \
+ rw2458n | \
wzr-hp-g300nh2 | \
wzr-hp-g300nh | \
wzr-hp-g450h | \
diff --git a/target/linux/ar71xx/config-2.6.39 b/target/linux/ar71xx/config-2.6.39
index 14b6287904..a6d2babba1 100644
--- a/target/linux/ar71xx/config-2.6.39
+++ b/target/linux/ar71xx/config-2.6.39
@@ -38,6 +38,7 @@ CONFIG_AR71XX_MACH_PB44=y
CONFIG_AR71XX_MACH_PB92=y
CONFIG_AR71XX_MACH_RB4XX=y
CONFIG_AR71XX_MACH_RB750=y
+CONFIG_AR71XX_MACH_RW2458N=y
CONFIG_AR71XX_MACH_TEW_632BRP=y
CONFIG_AR71XX_MACH_TL_MR3X20=y
CONFIG_AR71XX_MACH_TL_WA901ND=y
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
index 8979fdf826..c138217af3 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
@@ -144,6 +144,15 @@ config AR71XX_MACH_PB92
select AR71XX_DEV_LEDS_GPIO
select AR71XX_DEV_USB
+config AR71XX_MACH_RW2458N
+ bool "Redwave RW2458N board support"
+ select SOC_AR724X
+ select AR71XX_DEV_M25P80
+ select AR71XX_DEV_AP91_PCI if PCI
+ select AR71XX_DEV_GPIO_BUTTONS
+ select AR71XX_DEV_LEDS_GPIO
+ select AR71XX_DEV_USB
+
config AR71XX_MACH_AW_NR580
bool "AzureWave AW-NR580 board support"
select SOC_AR71XX
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
index 42c268026b..3125c124c7 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
@@ -53,6 +53,7 @@ obj-$(CONFIG_AR71XX_MACH_PB44) += mach-pb44.o
obj-$(CONFIG_AR71XX_MACH_PB92) += mach-pb92.o
obj-$(CONFIG_AR71XX_MACH_RB4XX) += mach-rb4xx.o
obj-$(CONFIG_AR71XX_MACH_RB750) += mach-rb750.o
+obj-$(CONFIG_AR71XX_MACH_RW2458N) += mach-rw2458n.o
obj-$(CONFIG_AR71XX_MACH_TEW_632BRP) += mach-tew-632brp.o
obj-$(CONFIG_AR71XX_MACH_TL_MR3020) += mach-tl-mr3020.o
obj-$(CONFIG_AR71XX_MACH_TL_MR3X20) += mach-tl-mr3x20.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-rw2458n.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-rw2458n.c
new file mode 100644
index 0000000000..02b655f135
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-rw2458n.c
@@ -0,0 +1,101 @@
+/*
+ * Redwave RW2458N support
+ *
+ * Copyright (C) 2011-2012 Cezary Jackiewicz <cezary@eko.one.pl>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-ap91-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-usb.h"
+
+#define RW2458N_GPIO_LED_D3 1
+#define RW2458N_GPIO_LED_D4 0
+#define RW2458N_GPIO_LED_D5 11
+#define RW2458N_GPIO_LED_D6 7
+#define RW2458N_GPIO_BTN_RESET 12
+
+#define RW2458N_KEYS_POLL_INTERVAL 20 /* msecs */
+#define RW2458N_KEYS_DEBOUNCE_INTERVAL (3 * RW2458N_KEYS_POLL_INTERVAL)
+
+static struct gpio_keys_button rw2458n_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = RW2458N_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = RW2458N_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+#define RW2458N_WAN_PHYMASK BIT(4)
+
+static struct gpio_led rw2458n_leds_gpio[] __initdata = {
+ {
+ .name = "rw2458n:green:d3",
+ .gpio = RW2458N_GPIO_LED_D3,
+ .active_low = 1,
+ }, {
+ .name = "rw2458n:green:d4",
+ .gpio = RW2458N_GPIO_LED_D4,
+ .active_low = 1,
+ }, {
+ .name = "rw2458n:green:d5",
+ .gpio = RW2458N_GPIO_LED_D5,
+ .active_low = 1,
+ }, {
+ .name = "rw2458n:green:d6",
+ .gpio = RW2458N_GPIO_LED_D6,
+ .active_low = 1,
+ }
+};
+
+static const char *rw2458n_part_probes[] = {
+ "RedBoot",
+ NULL,
+};
+
+static struct flash_platform_data rw2458n_flash_data = {
+ .part_probes = rw2458n_part_probes,
+};
+
+static void __init rw2458n_setup(void)
+{
+ u8 *mac1 = (u8 *) KSEG1ADDR(0x1fff0000);
+ u8 *mac2 = (u8 *) KSEG1ADDR(0x1fff0000 + ETH_ALEN);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+
+ ar71xx_add_device_m25p80(&rw2458n_flash_data);
+
+ ar71xx_add_device_mdio(0, ~RW2458N_WAN_PHYMASK);
+
+ ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac1, 0);
+ ar71xx_init_mac(ar71xx_eth1_data.mac_addr, mac2, 0);
+
+ ar71xx_add_device_eth(0);
+ ar71xx_add_device_eth(1);
+
+ ap91_pci_init(ee, NULL);
+
+ ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(rw2458n_leds_gpio),
+ rw2458n_leds_gpio);
+
+ ar71xx_register_gpio_keys_polled(-1, RW2458N_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(rw2458n_gpio_keys),
+ rw2458n_gpio_keys);
+
+ ar71xx_add_device_usb();
+}
+
+MIPS_MACHINE(AR71XX_MACH_RW2458N, "RW2458N", "Redwave RW2458N",
+ rw2458n_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h b/target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
index 522b0acdef..92eb88a1fb 100644
--- a/target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
+++ b/target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
@@ -49,6 +49,7 @@ enum ar71xx_mach_type {
AR71XX_MACH_RB_493, /* Mikrotik RouterBOARD 493/493AH */
AR71XX_MACH_RB_493G, /* Mikrotik RouterBOARD 493G */
AR71XX_MACH_RB_750, /* MikroTik RouterBOARD 750 */
+ AR71XX_MACH_RW2458N, /* Redwave RW2458N */
AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
AR71XX_MACH_TL_MR3020, /* TP-LINK TL-MR3020 */
AR71XX_MACH_TL_MR3220, /* TP-LINK TL-MR3220 */
diff --git a/target/linux/ar71xx/generic/profiles/redwave.mk b/target/linux/ar71xx/generic/profiles/redwave.mk
new file mode 100644
index 0000000000..069dd8f7be
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/redwave.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RW2458N
+ NAME:=Redwave RW2458N
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-ath9k wpad-mini
+endef
+
+define Profile/RW2458N/Description
+ Package set optimized for the Redwave RW2458N board.
+endef
+
+$(eval $(call Profile,RW2458N))
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 47a0b04e8a..72c5bd664a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -687,6 +687,11 @@ define Image/Build/Profile/DIR615C1
$(call Image/Build/Template/$(fs_squash)/$(1),Cameo913x,dir-615-c1,$(dir615c1_cmdline),"AP81-AR9130-RT-070614-02")
endef
+rw2458n_cmdline=board=RW2458N console=ttyS0,115200
+define Image/Build/Profile/RW2458N
+ $(call Image/Build/Template/$(fs_64k)/$(1),UBNTXM,rw2458n,$(rw2458n_cmdline),XM,UBNTXM,ar7240)
+endef
+
tew632brp_cmdline=board=TEW-632BRP console=ttyS0,115200
define Image/Build/Profile/TEW632BRP
$(call Image/Build/Template/$(fs_squash)/$(1),Cameo913x,tew-632brp,$(tew632brp_cmdline),"AP81-AR9130-RT-070614-00")
@@ -950,6 +955,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/PB42,$(1))
$(call Image/Build/Profile/PB44,$(1))
$(call Image/Build/Profile/PB92,$(1))
+ $(call Image/Build/Profile/RW2458N,$(1))
$(call Image/Build/Profile/TEW632BRP,$(1))
$(call Image/Build/Profile/TEW652BRP,$(1))
$(call Image/Build/Profile/TLMR3020,$(1))