aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-11-28 11:50:43 +0100
committerJohn Crispin <john@phrozen.org>2020-12-02 07:53:52 +0100
commit1dc5d56ca0d5aba6e4661f6027c4dec68c79b8dd (patch)
tree7944584201e5a392e7b6f34ff09b5a925b758400 /target
parent9aa449050297b58a41843bceaff6179458b64003 (diff)
downloadupstream-1dc5d56ca0d5aba6e4661f6027c4dec68c79b8dd.tar.gz
upstream-1dc5d56ca0d5aba6e4661f6027c4dec68c79b8dd.tar.bz2
upstream-1dc5d56ca0d5aba6e4661f6027c4dec68c79b8dd.zip
realtek: cleanup package selection
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/realtek/Makefile3
-rw-r--r--target/linux/realtek/image/Makefile3
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
index 98fcaf3968..02eefe26fb 100644
--- a/target/linux/realtek/Makefile
+++ b/target/linux/realtek/Makefile
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/target.mk
FEATURES := $(filter-out mips16,$(FEATURES))
DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
- dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
+ dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only \
+ ip-full ip-bridge tc
$(eval $(call BuildTarget))
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 4e9dbc350d..51356b3518 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -26,7 +26,6 @@ define Device/allnet_all-sg8208m
DEVICE_MODEL := ALL-SG8208M
UIMAGE_MAGIC := 0x00000006
UIMAGE_NAME := 2.2.2.0
- DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
endef
TARGET_DEVICES += allnet_all-sg8208m
@@ -34,7 +33,6 @@ define Device/d-link_dgs-1210
SOC := rtl8382
IMAGE_SIZE := 13824k
DEVICE_VENDOR := D-Link
- DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
endef
define Device/d-link_dgs-1210-10p
@@ -64,7 +62,6 @@ define Device/netgear_gs110tpp-v1
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := GS110TP
DEVICE_VARIANT := v1
- DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
endef
TARGET_DEVICES += netgear_gs110tpp-v1