aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tmn505@gmail.com>2021-05-25 15:26:06 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-06-06 00:26:13 +0200
commit1984a6bbcaac95c439dd4a6eba2f78c54e9be215 (patch)
tree1d774dee3d55ea73b06f48f5e618129c2c6738a1 /target
parent609aa3978393d7436e5c9caba89d3356af021c80 (diff)
downloadupstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.tar.gz
upstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.tar.bz2
upstream-1984a6bbcaac95c439dd4a6eba2f78c54e9be215.zip
ipq40xx: add uboot-envtools to default packages
When support for Luma WRTQ-329ACN was added, the instructions for flashing this device include using tools from uboot-envtools package. Unfortunately the OpenWrt buildroot system omits packages from DEVICE_PACKAGES when CONFIG_TARGET_MULTI_PROFILE, CONFIG_TARGET_PER_DEVICE_ROOTFS, CONFIG_TARGET_ALL_PROFILES are set. In result the official images are without tools mentioned in the instruction. The workoround for the fashing would be installing uboot-envtools when booted with initramfs image, but not always the access to internet is available. The other method would be to issue the necesary command in U-Boot environment but some serial terminals default configuration don't work well with pasting lines longer than 80 chars. Therefore add uboot-envtools to default packages, which adds really small flash footprint to rootfs, where increased size usually is not an issue. Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/Makefile3
-rw-r--r--target/linux/ipq40xx/image/generic.mk28
2 files changed, 14 insertions, 17 deletions
diff --git a/target/linux/ipq40xx/Makefile b/target/linux/ipq40xx/Makefile
index 43b1fcb0f9..400612376c 100644
--- a/target/linux/ipq40xx/Makefile
+++ b/target/linux/ipq40xx/Makefile
@@ -18,6 +18,7 @@ DEFAULT_PACKAGES += \
kmod-usb-dwc3-qcom \
kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
kmod-ath10k-ct wpad-basic-wolfssl \
- kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
+ kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct \
+ uboot-envtools
$(eval $(call BuildTarget))
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 2d6186ed99..68e565594d 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -131,8 +131,7 @@ define Device/alfa-network_ap120c-ac
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := AP120C-AC
SOC := qcom-ipq4018
- DEVICE_PACKAGES := kmod-usb-acm \
- kmod-tpm-i2c-atmel uboot-envtools
+ DEVICE_PACKAGES := kmod-usb-acm kmod-tpm-i2c-atmel
BLOCKSIZE := 128k
PAGESIZE := 2048
IMAGE_SIZE := 65536k
@@ -151,7 +150,6 @@ endef
define Device/aruba_ap-303
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-303
- DEVICE_PACKAGES += uboot-envtools
endef
TARGET_DEVICES += aruba_ap-303
@@ -164,7 +162,7 @@ TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
- DEVICE_PACKAGES += kmod-hwmon-ad7418 uboot-envtools
+ DEVICE_PACKAGES += kmod-hwmon-ad7418
endef
TARGET_DEVICES += aruba_ap-365
@@ -247,7 +245,7 @@ define Device/buffalo_wtr-m2133hp
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WTR-M2133HP
SOC := qcom-ipq4019
- DEVICE_PACKAGES := uboot-envtools ath10k-firmware-qca9984-ct ipq-wifi-buffalo_wtr-m2133hp
+ DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ipq-wifi-buffalo_wtr-m2133hp
BLOCKSIZE := 128k
PAGESIZE := 2048
endef
@@ -328,7 +326,7 @@ define Device/devolo_magic-2-wifi-next
IMAGE_SIZE := 26624k
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next uboot-envtools
+ DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
endef
TARGET_DEVICES += devolo_magic-2-wifi-next
@@ -367,7 +365,7 @@ define Device/edgecore_ecw5211
SOC := qcom-ipq4018
BLOCKSIZE := 128k
PAGESIZE := 2048
- DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm uboot-envtools
+ DEVICE_PACKAGES := kmod-tpm-i2c-atmel kmod-usb-acm
endef
TARGET_DEVICES += edgecore_ecw5211
@@ -551,7 +549,6 @@ define Device/linksys_ea6350v3
UBINIZE_OPTS := -E 5
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
- DEVICE_PACKAGES := uboot-envtools
endef
TARGET_DEVICES += linksys_ea6350v3
@@ -567,7 +564,7 @@ define Device/linksys_ea8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
- DEVICE_PACKAGES := uboot-envtools ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_ea8300
@@ -583,7 +580,7 @@ define Device/linksys_mr8300
UBINIZE_OPTS := -E 5 # EOD marks to "hide" factory sig at EOF
IMAGES += factory.bin
IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=MR8300
- DEVICE_PACKAGES := uboot-envtools ath10k-firmware-qca9888-ct ipq-wifi-linksys_mr8300-v0 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-linksys_mr8300-v0 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += linksys_mr8300
@@ -592,7 +589,7 @@ define Device/luma_wrtq-329acn
DEVICE_VENDOR := Luma Home
DEVICE_MODEL := WRTQ-329ACN
SOC := qcom-ipq4018
- DEVICE_PACKAGES := ipq-wifi-luma_wrtq-329acn kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio uboot-envtools
+ DEVICE_PACKAGES := ipq-wifi-luma_wrtq-329acn kmod-ath3k kmod-eeprom-at24 kmod-i2c-gpio
IMAGE_SIZE := 76632k
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -673,7 +670,6 @@ define Device/openmesh_a42
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := uboot-envtools
endef
TARGET_DEVICES += openmesh_a42
@@ -689,7 +685,7 @@ define Device/openmesh_a62
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A62
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct uboot-envtools
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
endef
TARGET_DEVICES += openmesh_a62
@@ -705,7 +701,7 @@ define Device/plasmacloud_pa1200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := uboot-envtools ipq-wifi-plasmacloud-pa1200
+ DEVICE_PACKAGES := ipq-wifi-plasmacloud-pa1200
endef
TARGET_DEVICES += plasmacloud_pa1200
@@ -721,7 +717,7 @@ define Device/plasmacloud_pa2200
IMAGES += factory.bin
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA2200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud-pa2200 uboot-envtools
+ DEVICE_PACKAGES := ath10k-firmware-qca9888-ct ipq-wifi-plasmacloud-pa2200
endef
TARGET_DEVICES += plasmacloud_pa2200
@@ -815,7 +811,7 @@ define Device/zyxel_nbg6617
# this minimum-size. However, the larger image can be flashed both ways.
IMAGE/factory.bin := append-rootfs | pad-rootfs | pad-to 64k | check-size $$$$(ROOTFS_SIZE) | zyxel-ras-image separate-kernel
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | check-size $$$$(ROOTFS_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
- DEVICE_PACKAGES := uboot-envtools kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += zyxel_nbg6617