aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2018-01-28 19:49:38 +0100
committerJohn Crispin <john@phrozen.org>2018-02-11 16:04:16 +0100
commit14951e8f8e09ba6e2cff140769189a66155a5345 (patch)
tree5a9e873b663e37d6324cda25e3d86032a093ead1 /target
parente39a240ba28c9081d861a6d4e01a70b61d6097d4 (diff)
downloadupstream-14951e8f8e09ba6e2cff140769189a66155a5345.tar.gz
upstream-14951e8f8e09ba6e2cff140769189a66155a5345.tar.bz2
upstream-14951e8f8e09ba6e2cff140769189a66155a5345.zip
ramips: add support for TP-Link Archer C50 v3
TP-Link Archer C50 v3 is a router with 5-port FE switch and non-detachable antennas. It's based on MediaTek MT7628N+MT7612E. Specification: - MediaTek MT7628N/N (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz and 2T2R 5 GHz - 5x 10/100 Mbps Ethernet - 4x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - 7x LED (GPIO-controlled*), 2x button, power switch * WAN LED in this devices is a dual-color, dual-leads type which isn't (fully) supported by gpio-leds driver. This type of LED requires both GPIOs state change at the same time to select color or turn it off. For now, we support/use only the green part of the LED. Flash instruction: The only way to flash LEDE image in ArcherC50v3 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "openwrt-ramips-mt7628-ArcherC50v3-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds6
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ArcherC50V3.dts94
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
6 files changed, 116 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 110b588339..677bf95a27 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -393,6 +393,12 @@ tplink,c20-v4)
ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan2g" "wlan0"
;;
+tplink,c50-v3)
+ ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
+ ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
+ ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan2g" "wlan1"
+ set_wifi_led "$boardname:green:wlan5g"
+ ;;
tplink,tl-mr3420-v5)
set_usb_led "$boardname:green:usb"
set_wifi_led "$boardname:green:wlan"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index d3855947db..d064bfef3b 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -175,6 +175,7 @@ ramips_setup_interfaces()
rb750gr3|\
rt-n14u|\
tplink,c20-v4|\
+ tplink,c50-v3|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 068df1df68..6b11fb2872 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -39,6 +39,7 @@ get_status_led() {
pwh2004|\
r6220|\
tplink,c20-v4|\
+ tplink,c50-v3|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 892dfe3fbe..45e141de02 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -244,6 +244,7 @@ platform_check_image() {
mr200|\
tplink,c20-v1|\
tplink,c20-v4|\
+ tplink,c50-v3|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/dts/ArcherC50V3.dts b/target/linux/ramips/dts/ArcherC50V3.dts
new file mode 100644
index 0000000000..9dd55ef21c
--- /dev/null
+++ b/target/linux/ramips/dts/ArcherC50V3.dts
@@ -0,0 +1,94 @@
+/dts-v1/;
+
+#include "TPLINK-8M.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "tplink,c50-v3", "mediatek,mt7628an-soc";
+ model = "TP-Link Archer C50 v3";
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio0 5 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ lan {
+ label = "c50-v3:green:lan";
+ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+ };
+
+ power {
+ label = "c50-v3:green:power";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "c50-v3:green:wan";
+ gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_orange {
+ label = "c50-v3:orange:wan";
+ gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "c50-v3:green:wlan2g";
+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan5 {
+ label = "c50-v3:green:wlan5g";
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "c50-v3:green:wps";
+ gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "gpio", "p0led_an", "p1led_an", "p2led_an",
+ "p3led_an", "p4led_an", "wdt", "wled_an";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+
+ pcie-bridge {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&factory 0x28000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ mtd-mac-address = <&factory 0xf100>;
+ mtd-mac-address-increment = <(-1)>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index d12aaf0eec..fe52809570 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -152,6 +152,19 @@ define Device/tplink_c20-v4
endef
TARGET_DEVICES += tplink_c20-v4
+define Device/tplink_c50-v3
+ $(Device/tplink)
+ DTS := ArcherC50V3
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link ArcherC50 v3
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0x001D9BA4
+ TPLINK_HWREV := 0x79
+ TPLINK_HWREVADD := 0x1
+ TPLINK_HVERSION := 3
+endef
+TARGET_DEVICES += tplink_c50-v3
+
define Device/tplink_tl-mr3420-v5
$(Device/tplink)
DTS := TL-MR3420V5