aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-07-11 14:41:08 +0900
committerChuanhong Guo <gch981213@gmail.com>2019-09-25 14:44:36 +0800
commit12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf (patch)
tree8b00dfdb3e70fc5240b5088c8a0677cc34087d7e /target
parentc1394dabf6547dbc25e9563ef980aed9589479ab (diff)
downloadupstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.tar.gz
upstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.tar.bz2
upstream-12ab6ef5c377e9d4aa8f0758ca92056da7eea0bf.zip
ramips: add support for I-O DATA WNPR2600G
I-O DATA WNPR2600G is a 2.4/5 GHz band 11ac router, based on MediaTek MT7621A. Specification: - SoC : MediaTek MT7621A - RAM : DDR3 128 MiB - Flash : SPI-NOR 16 MiB - WLAN : 2.4/5 GHz 4T4R - 2.4 GHz : MediaTek MT7615 - 5 GHz : MediaTek MT7615 - Ethernet : 10/100/1000 Mbps - Switch : MT7530 (SoC) - LED/keys : 4x/3x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J1: Vcc, RX, GND, TX from SoC side - 57600n8 Flash instruction using factory image: 1. Boot WNPR2600G normaly 2. Access to "http://192.168.0.1/" and open firmware update page ("ファームウェア") 3. Select the OpenWrt factory image and click update ("更新") button to perform firmware update 4. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ramips/dts/mt7621_iodata_wnpr2600g.dts165
-rw-r--r--target/linux/ramips/image/mt7621.mk13
3 files changed, 183 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 981d6c2596..d485010e3a 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -242,6 +242,7 @@ ramips_setup_interfaces()
huawei,hg255d|\
iodata,wn-ax1167gr|\
iodata,wn-gx300gr|\
+ iodata,wnpr2600g|\
iptime,a604m)
ucidef_add_switch "switch0" \
"1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "0:wan" "6@eth0"
@@ -670,6 +671,10 @@ ramips_setup_macs()
trendnet,tew-692gr)
wan_mac=$(macaddr_add "$(mtd_get_mac_binary factory 0x4)" 1)
;;
+ iodata,wnpr2600g)
+ wan_mac=$(mtd_get_mac_ascii u-boot-env wanaddr)
+ label_mac=$wan_mac
+ ;;
iptime,a3|\
iptime,a604m)
wan_mac=$(mtd_get_mac_binary u-boot 0x1fc40)
diff --git a/target/linux/ramips/dts/mt7621_iodata_wnpr2600g.dts b/target/linux/ramips/dts/mt7621_iodata_wnpr2600g.dts
new file mode 100644
index 0000000000..09bc9a3d56
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_iodata_wnpr2600g.dts
@@ -0,0 +1,165 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "iodata,wnpr2600g", "mediatek,mt7621-soc";
+ model = "I-O DATA WNPR2600G";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "wnpr2600g:green:power";
+ gpios = <&gpio0 7 GPIO_ACTIVE_HIGH>;
+ default-state = "on";
+ };
+
+ notification {
+ label = "wnpr2600g:green:notification";
+ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
+ };
+
+ wlan2g {
+ label = "wnpr2600g:green:wlan2g";
+ gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "phy0radio";
+ };
+
+ wlan5g {
+ label = "wnpr2600g:green:wlan5g";
+ gpios = <&gpio0 15 GPIO_ACTIVE_HIGH>;
+ linux,default-trigger = "phy1radio";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ auto {
+ label = "auto";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 16 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x030000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x030000 0x010000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x040000 0x010000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x050000 0xda0000>;
+ };
+
+ partition@df0000 {
+ label = "manufacture";
+ reg = <0xdf0000 0x190000>;
+ read-only;
+ };
+
+ partition@f80000 {
+ label = "storage";
+ reg = <0xf80000 0x080000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+ mediatek,portmap = "wllll";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "uart2", "uart3", "jtag", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&xhci {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4cf9cf7ff2..816652ddaa 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -322,6 +322,19 @@ define Device/iodata_wn-gx300gr
endef
TARGET_DEVICES += iodata_wn-gx300gr
+define Device/iodata_wnpr2600g
+ MTK_SOC := mt7621
+ DEVICE_VENDOR := I-O DATA
+ DEVICE_MODEL := WNPR2600G
+ IMAGE_SIZE := 13952k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ elx-header 0104003a 8844A2D168B45A2D
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += iodata_wnpr2600g
+
define Device/lenovo_newifi-d1
MTK_SOC := mt7621
IMAGE_SIZE := 32448k