aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-01 09:45:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-01 09:45:27 +0000
commit114632438a8d787127db0cb997fea058c4307d46 (patch)
treeb497701be54cb94120b37f299c2670b2061d0d7d /target
parent0f6020d1716b70b4915c1678ef7c99293b51996c (diff)
downloadupstream-114632438a8d787127db0cb997fea058c4307d46.tar.gz
upstream-114632438a8d787127db0cb997fea058c4307d46.tar.bz2
upstream-114632438a8d787127db0cb997fea058c4307d46.zip
Remove patch-cmdline from the packages and move it tools tools/. adm5120 and rb532 do use it for procuding ready-to-use kernels (#1631)
SVN-Revision: 7820
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile5
-rw-r--r--target/linux/rb532-2.6/image/Makefile4
2 files changed, 5 insertions, 4 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 360a87f657..ae869f6055 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -77,8 +77,13 @@ define Image/Build/MyLoader
$(IMGNAME)-$(3)-$(2).bin
endef
+define Image/cmdline/yaffs2
+root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+endef
+
define Image/Build/RouterBoard
$(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
+ $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
endef
define Image/Build
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 84f37e3bb2..555eb2a645 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -20,10 +20,6 @@ LOADER_MAKEOPTS= \
RAMSIZE=$(RAMSIZE) \
IMAGE_COPY=$(IMAGE_COPY)
-define Build/Compile
- $(CC) -o $(STAGING_DIR)/bin/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
-endef
-
define Build/Clean
$(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
endef