aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-16 08:03:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-16 08:03:53 +0000
commit0eb7f75195404e45d967be74e560d0da02dadbe2 (patch)
tree2b8beca1ae64d9a3db24df3f37844e4a9d01a33a /target
parentf4997ac854b2d2db37b3f5530a3d81e243c47f3b (diff)
downloadupstream-0eb7f75195404e45d967be74e560d0da02dadbe2.tar.gz
upstream-0eb7f75195404e45d967be74e560d0da02dadbe2.tar.bz2
upstream-0eb7f75195404e45d967be74e560d0da02dadbe2.zip
Add profile for Soekris Net4801 boards (#1072)
SVN-Revision: 6962
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86-2.6/config/default48
-rw-r--r--target/linux/x86-2.6/profiles/Soekris.mk16
2 files changed, 63 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/config/default b/target/linux/x86-2.6/config/default
index e9cf78f12c..e72bb7453e 100644
--- a/target/linux/x86-2.6/config/default
+++ b/target/linux/x86-2.6/config/default
@@ -124,6 +124,9 @@ CONFIG_GENERIC_ISA_DMA=y
# CONFIG_HIGHMEM64G is not set
# CONFIG_HPET_TIMER is not set
# CONFIG_HUGETLBFS is not set
+CONFIG_HWMON=m
+# CONFIG_HWMON_DEBUG_CHIP is not set
+CONFIG_HWMON_VID=m
CONFIG_HW_CONSOLE=y
CONFIG_HW_RANDOM=y
# CONFIG_HW_RANDOM_AMD is not set
@@ -150,6 +153,7 @@ CONFIG_I2C_CHARDEV=m
# CONFIG_I2C_ELEKTOR is not set
# CONFIG_I2C_I801 is not set
# CONFIG_I2C_I810 is not set
+CONFIG_I2C_ISA=m
# CONFIG_I2C_NFORCE2 is not set
# CONFIG_I2C_OCORES is not set
# CONFIG_I2C_PARPORT_LIGHT is not set
@@ -327,7 +331,7 @@ CONFIG_PAGE_OFFSET=0xC0000000
# CONFIG_PATA_TRIFLEX is not set
# CONFIG_PATA_VIA is not set
# CONFIG_PATA_WINBOND is not set
-# CONFIG_PC8736x_GPIO is not set
+CONFIG_PC8736x_GPIO=m
# CONFIG_PCIEPORTBUS is not set
# CONFIG_PCIPCWATCHDOG is not set
CONFIG_PCI_BIOS=y
@@ -396,13 +400,55 @@ CONFIG_SCx200_I2C_SDA=13
CONFIG_SCx200_WDT=m
# CONFIG_SECCOMP is not set
CONFIG_SEMAPHORE_SLEEPERS=y
+# CONFIG_SENSORS_ABITUGURU is not set
+# CONFIG_SENSORS_ADM1021 is not set
+# CONFIG_SENSORS_ADM1025 is not set
+# CONFIG_SENSORS_ADM1026 is not set
+# CONFIG_SENSORS_ADM1031 is not set
+# CONFIG_SENSORS_ADM9240 is not set
+# CONFIG_SENSORS_ASB100 is not set
+# CONFIG_SENSORS_ATXP1 is not set
# CONFIG_SENSORS_DS1337 is not set
# CONFIG_SENSORS_DS1374 is not set
+# CONFIG_SENSORS_DS1621 is not set
# CONFIG_SENSORS_EEPROM is not set
+# CONFIG_SENSORS_F71805F is not set
+# CONFIG_SENSORS_FSCHER is not set
+# CONFIG_SENSORS_FSCPOS is not set
+# CONFIG_SENSORS_GL518SM is not set
+# CONFIG_SENSORS_GL520SM is not set
+# CONFIG_SENSORS_HDAPS is not set
+# CONFIG_SENSORS_IT87 is not set
+# CONFIG_SENSORS_K8TEMP is not set
+# CONFIG_SENSORS_LM63 is not set
+# CONFIG_SENSORS_LM75 is not set
+# CONFIG_SENSORS_LM77 is not set
+# CONFIG_SENSORS_LM78 is not set
+# CONFIG_SENSORS_LM80 is not set
+# CONFIG_SENSORS_LM83 is not set
+# CONFIG_SENSORS_LM85 is not set
+# CONFIG_SENSORS_LM87 is not set
+# CONFIG_SENSORS_LM90 is not set
+# CONFIG_SENSORS_LM92 is not set
+# CONFIG_SENSORS_MAX1619 is not set
# CONFIG_SENSORS_MAX6875 is not set
+CONFIG_SENSORS_PC87360=m
# CONFIG_SENSORS_PCA9539 is not set
# CONFIG_SENSORS_PCF8574 is not set
# CONFIG_SENSORS_PCF8591 is not set
+# CONFIG_SENSORS_SIS5595 is not set
+# CONFIG_SENSORS_SMSC47B397 is not set
+# CONFIG_SENSORS_SMSC47M1 is not set
+# CONFIG_SENSORS_SMSC47M192 is not set
+# CONFIG_SENSORS_VIA686A is not set
+# CONFIG_SENSORS_VT1211 is not set
+# CONFIG_SENSORS_VT8231 is not set
+# CONFIG_SENSORS_W83627EHF is not set
+# CONFIG_SENSORS_W83627HF is not set
+# CONFIG_SENSORS_W83781D is not set
+# CONFIG_SENSORS_W83791D is not set
+# CONFIG_SENSORS_W83792D is not set
+# CONFIG_SENSORS_W83L785TS is not set
# CONFIG_SERIAL_8250_EXTENDED is not set
# CONFIG_SERIAL_8250_PNP is not set
CONFIG_SERIO=y
diff --git a/target/linux/x86-2.6/profiles/Soekris.mk b/target/linux/x86-2.6/profiles/Soekris.mk
new file mode 100644
index 0000000000..8cce126039
--- /dev/null
+++ b/target/linux/x86-2.6/profiles/Soekris.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Soekris
+ NAME:=Soekris Net4801
+ PACKAGES:=kmod-i2c-scx200 kmod-natsemi kmod-leds-net48xx kmod-scx200-gpio kmod-scx200-wdt kmod-hwmon-pc87360
+endef
+
+define Profile/Soekris/Description
+ Package set compatible with the Soekris Net4801. Contains I2C/LEDS/GPIO/Sensors support
+endef
+$(eval $(call Profile,Soekris))