aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2018-06-17 22:46:29 +0200
committerRafał Miłecki <rafal@milecki.pl>2018-06-17 22:46:29 +0200
commit0da9303e5b444e2c98c24719c48c09f4c976c5a7 (patch)
tree2ab7fd140ff27b9762862f3a9556884c3f08756b /target
parente53d0da775082ee5d1d18949b00850590cf81650 (diff)
downloadupstream-0da9303e5b444e2c98c24719c48c09f4c976c5a7.tar.gz
upstream-0da9303e5b444e2c98c24719c48c09f4c976c5a7.tar.bz2
upstream-0da9303e5b444e2c98c24719c48c09f4c976c5a7.zip
mac80211: backport "brcmfmac: cleanup and some rework" from 4.17
It was described by Arend as: > This series is intended for 4.17 and includes following: > > * rework bus layer attach code. > * remove duplicate variable declaration. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/bcm53xx/image/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/bcm53xx/image/Makefile b/target/linux/bcm53xx/image/Makefile
index 596cb5ddb2..5cc5686cd0 100644
--- a/target/linux/bcm53xx/image/Makefile
+++ b/target/linux/bcm53xx/image/Makefile
@@ -244,6 +244,36 @@ define Device/linksys-ea9500
endef
# TARGET_DEVICES += linksys-ea9500
+define Device/luxul-xap-1410
+ DEVICE_TITLE := Luxul XAP-1410
+ IMAGE/trx := append-rootfs | trx-serial
+endef
+TARGET_DEVICES += luxul-xap-1410
+
+define Device/luxul-xap-1510
+ DEVICE_TITLE := Luxul XAP-1510
+ IMAGE/trx := append-rootfs | trx-serial
+endef
+TARGET_DEVICES += luxul-xap-1510
+
+define Device/luxul-xwc-1000
+ DEVICE_TITLE := Luxul XWC-1000
+ IMAGE/trx := append-rootfs | trx-serial
+endef
+TARGET_DEVICES += luxul-xwc-1000
+
+define Device/luxul-xwr-1200
+ DEVICE_TITLE := Luxul XWR-1200
+ DEVICE_PACKAGES := $(USB2_PACKAGES)
+endef
+TARGET_DEVICES += luxul-xwr-1200
+
+define Device/luxul-xwr-3100
+ DEVICE_TITLE := Luxul XWR-3100
+ DEVICE_PACKAGES := $(IEEE8021X) kmod-brcmfmac $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += luxul-xwr-3100
+
define Device/netgear
IMAGES := chk
IMAGE/chk := append-ubi | trx-nand | netgear-chk