aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTee Hao Wei <angelsl@in04.sg>2021-07-06 01:19:08 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-07-11 16:58:12 +0200
commit0c721434ea56044cdc1c13554c970b82471bc43e (patch)
tree1958a1afe97efeb88bba3fe67be2833223db5ba6 /target
parentc13d7c82aa4cd2cbf1f61bad857cd01b795318e3 (diff)
downloadupstream-0c721434ea56044cdc1c13554c970b82471bc43e.tar.gz
upstream-0c721434ea56044cdc1c13554c970b82471bc43e.tar.bz2
upstream-0c721434ea56044cdc1c13554c970b82471bc43e.zip
ramips: add support for Linksys EA8100 v2
Specifications: - SoC: MT7621AT - RAM: 256MB - Flash: 128MB NAND - Ethernet: 5 Gigabit ports - WiFi: 2.4G/5G MT7615N - USB: 1 USB 3.0, 1 USB 2.0 This device is very similar to the EA7300 v1/v2, EA7500 v2, and EA8100 v1. Installation: Upload the generated factory image through the factory web interface. (following part taken from EA7300 v2 commit message:) This might fail due to the A/B nature of this device. When flashing, OEM firmware writes over the non-booted partition. If booted from 'A', flashing over 'B' won't work. To get around this, you should flash the OEM image over itself. This will then boot the router from 'B' and allow you to flash OpenWRT without problems. Reverting to factory firmware: Hard-reset the router three times to force it to boot from 'B.' This is where the stock firmware resides. To remove any traces of OpenWRT from your router simply flash the OEM image at this point. With thanks to Tom Wizetek (@wizetek) for testing. Signed-off-by: Tee Hao Wei <angelsl@in04.sg>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/mt7621_linksys_ea8100-v2.dts8
-rw-r--r--target/linux/ramips/image/mt7621.mk8
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/01_leds3
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/init.d/bootcount3
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh1
7 files changed, 25 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7621_linksys_ea8100-v2.dts b/target/linux/ramips/dts/mt7621_linksys_ea8100-v2.dts
new file mode 100644
index 0000000000..db1429ea10
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_linksys_ea8100-v2.dts
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_linksys_ea7xxx.dtsi"
+
+/ {
+ compatible = "linksys,ea8100-v2", "mediatek,mt7621-soc";
+ model = "Linksys EA8100 v2";
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 63d28530b6..853741f9af 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -870,6 +870,14 @@ define Device/linksys_ea8100-v1
endef
TARGET_DEVICES += linksys_ea8100-v1
+define Device/linksys_ea8100-v2
+ $(Device/linksys_ea7xxx)
+ DEVICE_MODEL := EA8100
+ DEVICE_VARIANT := v2
+ LINKSYS_HWNAME := EA8100v2
+endef
+TARGET_DEVICES += linksys_ea8100-v2
+
define Device/linksys_re6500
$(Device/dsa-migration)
IMAGE_SIZE := 7872k
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
index cb889de208..9545d8d0c7 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
@@ -55,7 +55,8 @@ linksys,e5600)
linksys,ea7300-v1|\
linksys,ea7300-v2|\
linksys,ea7500-v2|\
-linksys,ea8100-v1)
+linksys,ea8100-v1|\
+linksys,ea8100-v2)
ucidef_set_led_netdev "lan1" "lan1 link" "green:lan1" "lan1" "link"
ucidef_set_led_netdev "lan2" "lan2 link" "green:lan2" "lan2" "link"
ucidef_set_led_netdev "lan3" "lan3 link" "green:lan3" "lan3" "link"
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index aa1d644938..16148547f7 100644
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -143,7 +143,8 @@ ramips_setup_macs()
linksys,ea7300-v1|\
linksys,ea7300-v2|\
linksys,ea7500-v2|\
- linksys,ea8100-v1)
+ linksys,ea8100-v1|\
+ linksys,ea8100-v2)
lan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
wan_mac=$lan_mac
label_mac=$lan_mac
diff --git a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
index 24d73b039d..ee847e947b 100644
--- a/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
+++ b/target/linux/ramips/mt7621/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
@@ -28,7 +28,8 @@ case "$board" in
linksys,ea7300-v1|\
linksys,ea7300-v2|\
linksys,ea7500-v2|\
- linksys,ea8100-v1)
+ linksys,ea8100-v1|\
+ linksys,ea8100-v2)
hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
[ "$PHYNBR" = "0" ] && macaddr_add $hw_mac_addr 1 > /sys${DEVPATH}/macaddress
[ "$PHYNBR" = "1" ] && macaddr_add $hw_mac_addr 2 > /sys${DEVPATH}/macaddress
diff --git a/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount b/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
index d3525ea0c9..7b4a63d663 100755
--- a/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
+++ b/target/linux/ramips/mt7621/base-files/etc/init.d/bootcount
@@ -12,7 +12,8 @@ boot() {
linksys,ea7300-v1|\
linksys,ea7300-v2|\
linksys,ea7500-v2|\
- linksys,ea8100-v1)
+ linksys,ea8100-v1|\
+ linksys,ea8100-v2)
mtd resetbc s_env || true
;;
samknows,whitebox-v8)
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index c2ad4d3ed6..18fea53aee 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -63,6 +63,7 @@ platform_do_upgrade() {
linksys,ea7300-v2|\
linksys,ea7500-v2|\
linksys,ea8100-v1|\
+ linksys,ea8100-v2|\
netgear,r6220|\
netgear,r6260|\
netgear,r6350|\