aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-05-30 22:25:02 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-06-11 19:06:49 +0200
commit05e276c0710c490616d3516e66dde606370af387 (patch)
tree0fc03dc09a5f7e8c67e110d11751a29d969872e8 /target
parentc4022243d8fe198b41488bc736f1c6cc3c7895bf (diff)
downloadupstream-05e276c0710c490616d3516e66dde606370af387.tar.gz
upstream-05e276c0710c490616d3516e66dde606370af387.tar.bz2
upstream-05e276c0710c490616d3516e66dde606370af387.zip
ar71xx: image: drop redundant uboot-envtools from DEVICE_PACKAGES
uboot-envtools is already included in DEFAULT_PACKAGES for ar71xx. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 8472b904cc..b5aabf4236 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -151,7 +151,7 @@ TARGET_DEVICES += gl-ar300
define Device/gl-ar300m
DEVICE_TITLE := GL AR300M
- DEVICE_PACKAGES := kmod-usb-core kmod-usb2 uboot-envtools
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
BOARDNAME = GL-AR300M
IMAGE_SIZE = 16000k
MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
@@ -288,7 +288,6 @@ TARGET_DEVICES += wndr3700 wndr3700v2 wndr3800 wndr3800ch wndrmac wndrmacv2
define Device/cap324
DEVICE_TITLE := PowerCloud CAP324 Cloud AP
- DEVICE_PACKAGES := uboot-envtools
BOARDNAME := CAP324
DEVICE_PROFILE := CAP324
IMAGE_SIZE = 15296k
@@ -299,7 +298,6 @@ TARGET_DEVICES += cap324
define Device/cap324-nocloud
DEVICE_TITLE := PowerCloud CAP324 Cloud AP (No-Cloud)
- DEVICE_PACKAGES := uboot-envtools
BOARDNAME := CAP324
DEVICE_PROFILE := CAP324
IMAGE_SIZE = 16000k
@@ -310,7 +308,6 @@ TARGET_DEVICES += cap324-nocloud
define Device/cr3000
DEVICE_TITLE := PowerCloud CR3000 Cloud Router
- DEVICE_PACKAGES := uboot-envtools
BOARDNAME := CR3000
DEVICE_PROFILE := CR3000
IMAGE_SIZE = 7104k
@@ -321,7 +318,6 @@ TARGET_DEVICES += cr3000
define Device/cr3000-nocloud
DEVICE_TITLE := PowerCloud CR3000 (No-Cloud)
- DEVICE_PACKAGES := uboot-envtools
BOARDNAME := CR3000
DEVICE_PROFILE := CR3000
IMAGE_SIZE = 7808k
@@ -332,7 +328,7 @@ TARGET_DEVICES += cr3000-nocloud
define Device/cr5000
DEVICE_TITLE := PowerCloud CR5000 Cloud Router
- DEVICE_PACKAGES := uboot-envtools kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-core
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-core
BOARDNAME := CR5000
DEVICE_PROFILE := CR5000
IMAGE_SIZE = 7104k
@@ -343,7 +339,7 @@ TARGET_DEVICES += cr5000
define Device/cr5000-nocloud
DEVICE_TITLE := PowerCloud CR5000 (No-Cloud)
- DEVICE_PACKAGES := uboot-envtools kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-core
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport kmod-usb-core
BOARDNAME := CR5000
DEVICE_PROFILE := CR5000
IMAGE_SIZE = 7808k
@@ -764,7 +760,7 @@ endef
define Device/dap-2695-a1
DEVICE_TITLE := D-Link DAP-2695 rev. A1
- DEVICE_PACKAGES := ath10k-firmware-qca988x kmod-ath10k uboot-envtools
+ DEVICE_PACKAGES := ath10k-firmware-qca988x kmod-ath10k
BOARDNAME = DAP-2695-A1
IMAGES := factory.img sysupgrade.bin
IMAGE_SIZE = 15360k