aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-05 01:01:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-05 01:01:27 +0000
commit05014415c10dc16db60f98e06fb49f86ca68600c (patch)
tree9fe6e607c6dcbde6d4e06ca04fcb9d008c04e43d /target
parent56172a1eba857dcb05ae310416c8eee0634fda1b (diff)
downloadupstream-05014415c10dc16db60f98e06fb49f86ca68600c.tar.gz
upstream-05014415c10dc16db60f98e06fb49f86ca68600c.tar.bz2
upstream-05014415c10dc16db60f98e06fb49f86ca68600c.zip
only build avr32 u-boot if requested, fixes build failure in default config
SVN-Revision: 12116
Diffstat (limited to 'target')
-rw-r--r--target/linux/avr32/image/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 2cef2653bf..c74efbe1df 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -8,13 +8,15 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+ define Build/Clean
$(MAKE) -C u-boot clean
-endef
+ endef
-define Build/Compile
+ define Build/Compile
$(MAKE) -C u-boot compile
-endef
+ endef
+endif
define Image/Prepare
cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage