aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-08-29 21:08:55 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-08-29 21:08:55 +0000
commit014765e77cc3ae594f482ac98f9ca4fa08c29981 (patch)
tree8d4aa282af59ca60ab15a4fc371c16123603b1b7 /target
parent00e17f0ba4ef8de91240a616abccefce1fcfb785 (diff)
downloadupstream-014765e77cc3ae594f482ac98f9ca4fa08c29981.tar.gz
upstream-014765e77cc3ae594f482ac98f9ca4fa08c29981.tar.bz2
upstream-014765e77cc3ae594f482ac98f9ca4fa08c29981.zip
Align jffs2 to pagesize and fix mkfs2.jffs2 opts
SVN-Revision: 22836
Diffstat (limited to 'target')
-rw-r--r--target/linux/kirkwood/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index ee29a95b6c..129ad95662 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2OPTS_NAND += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
define Image/Prepare
cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
@@ -25,6 +25,11 @@ define Image/Build
)
endef
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+ bs=2048 conv=sync
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \