aboutsummaryrefslogtreecommitdiffstats
path: root/target/utils/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-06 23:41:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-06 23:41:38 +0000
commitebdcc6d40c1abb39c248b90e83f653ffd429578a (patch)
tree1d8972d0bbb00d81613edd4c1f7de1f63702c988 /target/utils/Makefile
parent98910471a788906e794d00793e82d089cad58d1a (diff)
downloadupstream-ebdcc6d40c1abb39c248b90e83f653ffd429578a.tar.gz
upstream-ebdcc6d40c1abb39c248b90e83f653ffd429578a.tar.bz2
upstream-ebdcc6d40c1abb39c248b90e83f653ffd429578a.zip
move target/utils to tools/firmware-utils
SVN-Revision: 5702
Diffstat (limited to 'target/utils/Makefile')
-rw-r--r--target/utils/Makefile32
1 files changed, 0 insertions, 32 deletions
diff --git a/target/utils/Makefile b/target/utils/Makefile
deleted file mode 100644
index d11d7442f2..0000000000
--- a/target/utils/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-TARGETS := addpattern trx motorola-bin dgfirmware trx2usr
-
-UTILS_BUILD_DIR:=$(BUILD_DIR)/target-utils
-
-download:
-prepare: $(UTILS_BUILD_DIR)
-compile: prepare $(patsubst %,$(UTILS_BUILD_DIR)/%,$(TARGETS)) FORCE
- mkdir -p $(STAGING_DIR)/bin
- $(CP) $(UTILS_BUILD_DIR)/* $(STAGING_DIR)/bin/
-install: compile
-package:
-clean: FORCE
- rm -rf $(UTILS_BUILD_DIR)
- for f in $(TARGETS); do \
- rm -f $(STAGING_DIR)/bin/$$f ; \
- done
-
-$(UTILS_BUILD_DIR):
- mkdir -p $(UTILS_BUILD_DIR)
-
-$(UTILS_BUILD_DIR)/%: src/%.c
- $(CC) -O2 -I $(STAGING_DIR)/include-host -include endian.h -o $@ $(patsubst $(UTILS_BUILD_DIR)/%,src/%.c,$@)
- chmod 755 $@
-