aboutsummaryrefslogtreecommitdiffstats
path: root/target/toolchain
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-07 21:01:37 +0000
commite9c10a0c8e4511e19a31f983162c171ab4dccba2 (patch)
tree22a45ecacb486499d94597fa13e046bdfb960f2c /target/toolchain
parentccc33238a418bfacf6a7f97433e092fe72e9f74b (diff)
downloadupstream-e9c10a0c8e4511e19a31f983162c171ab4dccba2.tar.gz
upstream-e9c10a0c8e4511e19a31f983162c171ab4dccba2.tar.bz2
upstream-e9c10a0c8e4511e19a31f983162c171ab4dccba2.zip
toolchain: respect CONFIG_VERSION_FILENAMES and add host system suffix
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44311
Diffstat (limited to 'target/toolchain')
-rw-r--r--target/toolchain/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/target/toolchain/Makefile b/target/toolchain/Makefile
index 6e60a08231..67c908530f 100644
--- a/target/toolchain/Makefile
+++ b/target/toolchain/Makefile
@@ -13,10 +13,7 @@ include $(INCLUDE_DIR)/host.mk
override MAKEFLAGS=
-PKG_OS:=$(word 2,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-PKG_CPU:=$(word 1,$(subst -, ,$(shell $(HOSTCC) -dumpmachine)))
-
-TOOLCHAIN_NAME:=OpenWrt-Toolchain-$(BOARD)-for-$(ARCH)$(ARCH_SUFFIX)-gcc-$(GCCV)$(DIR_SUFFIX)
+TOOLCHAIN_NAME:=OpenWrt-Toolchain-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))_gcc-$(GCCV)$(DIR_SUFFIX).$(HOST_OS)-$(HOST_ARCH)
TOOLCHAIN_BUILD_DIR:=$(BUILD_DIR)/$(TOOLCHAIN_NAME)
EXCLUDE_DIRS:=*/ccache \
*/initial \