aboutsummaryrefslogtreecommitdiffstats
path: root/target/toolchain
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 21:51:14 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 21:56:29 +0100
commit4894a3ff2870438cf812d88704c92c8d997a69db (patch)
treef2f22934b7f80503e0865d436e4b4f30ca2c11bf /target/toolchain
parentf118be07126e88f2fd393909675d815e0b0fd315 (diff)
downloadupstream-4894a3ff2870438cf812d88704c92c8d997a69db.tar.gz
upstream-4894a3ff2870438cf812d88704c92c8d997a69db.tar.bz2
upstream-4894a3ff2870438cf812d88704c92c8d997a69db.zip
target: fix copying of licenses for SDK/toolchain
The SDK and target/toolchain copy the license file into their directories. During the rename/move from LICENSE to a LICENSES folder, this has not been updated. Update it now, and include the new COPYING file. While at it, improve formatting/indent. Fixes: 882e3014610b ("LICENSES: include all used licenses in LICENSES directory") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/toolchain')
-rw-r--r--target/toolchain/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/target/toolchain/Makefile b/target/toolchain/Makefile
index 5002ff7835..c3ba70db04 100644
--- a/target/toolchain/Makefile
+++ b/target/toolchain/Makefile
@@ -33,7 +33,10 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX) | \
$(TAR) -xf - -C $(TOOLCHAIN_BUILD_DIR)
- $(CP) $(TOPDIR)/LICENSE ./files/README.TOOLCHAIN \
+ $(CP) \
+ $(TOPDIR)/LICENSES \
+ $(TOPDIR)/COPYING \
+ ./files/README.TOOLCHAIN \
$(TOOLCHAIN_BUILD_DIR)/
$(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh