aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-08-30 15:45:06 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-03 10:45:25 +0200
commitefaaadb49e90b51ba3a6adc6fafc330c23b8f764 (patch)
tree1552254b538cfa39c9553dc4c43d36cbedd7c5ed /target/sdk
parentfe43969336201f2cc7d103b68fd6e65989bee184 (diff)
downloadupstream-efaaadb49e90b51ba3a6adc6fafc330c23b8f764.tar.gz
upstream-efaaadb49e90b51ba3a6adc6fafc330c23b8f764.tar.bz2
upstream-efaaadb49e90b51ba3a6adc6fafc330c23b8f764.zip
sdk: use bundle-libraries.sh to ship kernel objtool tools
Ensure that the kernel objtool utilities are processed by the library bundler in order to ensure that they're usable on foreign systems with different libc versions. Fixes: a9f6fceb42 ("sdk: fix building external modules when CONFIG_STACK_VALIDATION=y") Acked-by: Yousong Zhou <yszhou4tech@gmail.com> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 2badc31429..6d81834720 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -71,6 +71,7 @@ KERNEL_FILES_BASE := \
.config \
Makefile \
scripts \
+ tools/objtool \
include \
Module.symvers \
modules.builtin \
@@ -95,16 +96,9 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)
- # Copy objtool executables. They are required for building external
- # modules if "Compile-time stack metadata validation" is enabled.
- if grep -q '^CONFIG_STACK_VALIDATION=y' $(LINUX_DIR)/.config; then \
- $(TAR) -cf - -C $(TOPDIR) \
- `cd $(TOPDIR); find $(KDIR_BASE)/tools/objtool -type f -executable` | \
- $(TAR) -xf - -C $(SDK_BUILD_DIR); \
- fi
-
(cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
$(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
+ $(KDIR_BASE) \
-type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))
@-( \