aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-11-01 17:31:40 +0100
committerPetr Štetiar <ynezz@true.cz>2020-11-02 08:39:49 +0100
commitec0ec0428e12b6a7cdad40fbe98d375ea15b45c5 (patch)
tree42984dc8f6975a50572b6d82be1fc0b4d9f42efa /target/sdk
parentf52aee0455f6ce77b16a78ddf17f1ef49ddc2380 (diff)
downloadupstream-ec0ec0428e12b6a7cdad40fbe98d375ea15b45c5.tar.gz
upstream-ec0ec0428e12b6a7cdad40fbe98d375ea15b45c5.tar.bz2
upstream-ec0ec0428e12b6a7cdad40fbe98d375ea15b45c5.zip
sdk: fix missing include directories
It's not possible to compile some applications which are using `-Werror=missing-include-dirs` compiler flags with the SDK as some target directories are missing in the SDK tarball: cc1: error: staging_dir/target/usr/include: No such file or directory [-Werror=missing-include-dirs] cc1: error: staging_dir/target/include: No such file or directory [-Werror=missing-include-dirs] Fix this by adding the missing directories in the SDK. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 4a9dc8be41..caec7178e9 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -82,7 +82,12 @@ KERNEL_FILES := $(patsubst $(TOPDIR)/%,%,$(wildcard $(addprefix $(LINUX_DIR)/,$(
all: compile
$(BIN_DIR)/$(SDK_NAME).tar.xz: clean
- mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
+ mkdir -p \
+ $(SDK_BUILD_DIR)/dl \
+ $(SDK_BUILD_DIR)/package \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/include \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/usr/include
+
$(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
`cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \