aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2017-12-04 12:48:30 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-12-05 22:56:31 +0100
commitdeaf9597c67aa970c27c333d9c69e3c3ad046248 (patch)
tree7c7e1764a44a6e949e9485740e288421da5049aa /target/sdk
parente23ff063d3d1ee6820daf170a2c4c0e1810e4591 (diff)
downloadupstream-deaf9597c67aa970c27c333d9c69e3c3ad046248.tar.gz
upstream-deaf9597c67aa970c27c333d9c69e3c3ad046248.tar.bz2
upstream-deaf9597c67aa970c27c333d9c69e3c3ad046248.zip
sdk: restrict base feed repo to public git for CONFIG_BUILDBOT only
This allows people to build SDK from custom repository (git access using ssh) and keep original URL in SDK's feeds.conf.default. Signed-off-by: Rafał Miłecki <rafal@milecki.pl> Acked-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index ae65fd1c8f..bf8c3ca2c6 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -36,7 +36,8 @@ SDK_DIRS = \
$(STAGING_SUBDIR_HOST) \
$(STAGING_SUBDIR_TOOLCHAIN)
-GIT_URL:=$(filter git://% http://% https://%,$(shell git config --get remote.origin.url 2>/dev/null))
+GIT_URL:=$(shell git config --get remote.origin.url 2>/dev/null)
+GIT_URL:=$(if $(CONFIG_BUILDBOT),$(filter git://% http://% https://%,$(GIT_URL)),$(GIT_URL))
GIT_COMMIT:=$(shell git rev-parse HEAD 2>/dev/null)
GIT_BRANCH:=$(filter-out master HEAD,$(shell git rev-parse --abbrev-ref HEAD 2>/dev/null))
GIT_TAGNAME:=$(shell git show-ref --tags --dereference 2>/dev/null | sed -ne '/^$(GIT_COMMIT) / { s|^.*/||; s|\^.*||; p }')