aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-08-01 09:11:17 +0200
committerJo-Philipp Wich <jo@mein.io>2018-08-01 09:12:17 +0200
commitd0e0b7049f88774e67c3d5ad6b573f7070e5f900 (patch)
treeedbb6628f964db8f6138cff6f14e9f1583e4246d /target/sdk
parentfdd6c556ab42d040efcc92a53149e3f8ec357f69 (diff)
downloadupstream-d0e0b7049f88774e67c3d5ad6b573f7070e5f900.tar.gz
upstream-d0e0b7049f88774e67c3d5ad6b573f7070e5f900.tar.bz2
upstream-d0e0b7049f88774e67c3d5ad6b573f7070e5f900.zip
sdk: bundle usbip userspace sources
Bundle the usbip utility sources shipped with the Linux kernel tree in order to allow the usbip packages from the package feed to build within the OpenWrt SDK. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d3822a0df6..499c2809dd 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -84,6 +84,10 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(SDK_DIRS) $(KERNEL_FILES) | \
$(TAR) -xf - -C $(SDK_BUILD_DIR)
+ # Copy usbip sources, this is required for the usbip userspace packages to be buildable by the SDK.
+ $(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
+ $(TAR) -xf - -C $(SDK_BUILD_DIR)
+
(cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
$(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
-type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))