aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-24 15:29:20 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-24 15:31:12 +0100
commitbeb69e242e9ff5873002d29456aa39985fb94bfc (patch)
treeddf3c5b001607f5c3ce0aa2df4ccd42a584f59de /target/sdk
parent807461e11c8e8d86f28fc642966eb1f83a3b08f1 (diff)
downloadupstream-beb69e242e9ff5873002d29456aa39985fb94bfc.tar.gz
upstream-beb69e242e9ff5873002d29456aa39985fb94bfc.tar.bz2
upstream-beb69e242e9ff5873002d29456aa39985fb94bfc.zip
sdk: explicitely remove ccache directories when packing SDK
Upon first invocation, the ccache program will create the required directory hierarchy so there is no point in shipping these empty directories. Removing those paths also avoids shipping dangling symlinks in case the directories got linked elsewhere, e.g. into a shared global cache. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 47a7382d24..5108cec441 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -17,6 +17,7 @@ SDK_NAME:=$(VERSION_DIST_SANITIZED)-sdk-$(if $(CONFIG_VERSION_FILENAMES),$(VERSI
SDK_BUILD_DIR:=$(BUILD_DIR)/$(SDK_NAME)
STAGING_SUBDIR_HOST := staging_dir/host
+STAGING_SUBDIR_TARGET := staging_dir/$(TARGET_DIR_NAME)
STAGING_SUBDIR_TOOLCHAIN := staging_dir/toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)_$(LIBC)-$(LIBCV)$(if $(CONFIG_arm),_eabi)
EXCLUDE_DIRS:=*/ccache/* \
@@ -118,6 +119,11 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(TOPDIR)/package/kernel/linux \
$(SDK_BUILD_DIR)/package/
+ -rm -rf \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/ccache \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/ccache \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache
+
-rm -f $(SDK_BUILD_DIR)/feeds.conf.default
$(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)
if [ -f $(TOPDIR)/feeds.conf ]; then \