aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorKarl Vogel <karl.vogel@gmail.com>2018-11-29 09:07:21 +0100
committerKarl Vogel <karl.vogel@gmail.com>2018-11-29 09:36:14 +0100
commitae980458abf8299d614f4b34add32e18d054378d (patch)
tree6800afd8248fa67c0a057299c69d5749def0ae92 /target/sdk
parent8ba6e95eed4676aa38cb367d2ecbf6e09270d2cb (diff)
downloadupstream-ae980458abf8299d614f4b34add32e18d054378d.tar.gz
upstream-ae980458abf8299d614f4b34add32e18d054378d.tar.bz2
upstream-ae980458abf8299d614f4b34add32e18d054378d.zip
sdk: find kernel modules when KDIR is a symlink
The find statement would not return any results if the KDIR_BASE pointed to a symlink. Ran into this issue due to a custom Kernel/Prepare that was installing a symlink to the kernel directory. The extra slash at the end fixes this scenario and does no harm for targets that have a proper KDIR. Signed-off-by: Karl Vogel <karl.vogel@gmail.com>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index a9df8be7d2..95ac3be197 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -83,7 +83,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
$(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
- `cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
+ `cd $(TOPDIR); find $(KDIR_BASE)/ -name \*.ko` \
`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \
-type f -name '*.bin' -or -name '*.cis' -or -name '*.csp' -or -name '*.dsp' -or -name '*.fw'` \
$(foreach exclude,$(EXCLUDE_DIRS),--exclude="$(exclude)") \