aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-18 03:15:31 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-18 03:18:53 +0100
commita68b1b9c8a4ca4f07494810e574172cbbfae2c87 (patch)
tree5248d927bcb2373d70e6fab5e4f62452e53b892b /target/sdk
parent0d1b32991469781209eff6a9ad7dc9fc52226231 (diff)
downloadupstream-a68b1b9c8a4ca4f07494810e574172cbbfae2c87.tar.gz
upstream-a68b1b9c8a4ca4f07494810e574172cbbfae2c87.tar.bz2
upstream-a68b1b9c8a4ca4f07494810e574172cbbfae2c87.zip
sdk: do not strip static libraries
Do not strip static libraries shipped with the SDK in order to preserve the archive index. If we strip the index of the shipped libraries, host programs will fail to link these libraries with errors like: libssl.a: error adding symbols: Archive has no index; run ranlib to add one The error was found while investigating a Python host build failure within the SDK environment. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index e9599c3c69..496f025393 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -92,7 +92,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
find \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/lib \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/usr/lib \
- -type f -name \*.so\* -or -name \*.a; \
+ -type f -name \*.so\*; \
) | xargs strip 2>/dev/null >/dev/null
mkdir -p $(SDK_BUILD_DIR)/target/linux