aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-13 11:45:43 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-13 11:46:14 +0100
commit90728c796d328f0c37475799711e88ba87259285 (patch)
tree76e1c0a61ced1f84f5e0042e481cbb35f5447a29 /target/sdk
parentfcea190b8bc0c4013e2fef7b57188cf5c548c7de (diff)
downloadupstream-90728c796d328f0c37475799711e88ba87259285.tar.gz
upstream-90728c796d328f0c37475799711e88ba87259285.tar.bz2
upstream-90728c796d328f0c37475799711e88ba87259285.zip
sdk: clean scripts/config before packing tarball (FS#504)
Avoids shipping potentially incompatible object files and also reduces the tarball size Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 719b659d25..ecaa015595 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -137,6 +137,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf
+ -make -C $(SDK_BUILD_DIR)/scripts/config clean
(cd $(BUILD_DIR); \
tar -I 'xz -7e' -cf $@ $(SDK_NAME); \
)