aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@cshore.thecshore.com>2016-09-29 04:14:17 -0400
committerJohn Crispin <john@phrozen.org>2016-09-30 00:39:25 +0200
commit71370d2c5543b3073653b601aba26078fdbab682 (patch)
treef33ca57ac0c120f3c6e6de7bc7ec641a9eff8f21 /target/sdk
parentc3d3111831d49d1ab37d90bbe6a61f1b2263721d (diff)
downloadupstream-71370d2c5543b3073653b601aba26078fdbab682.tar.gz
upstream-71370d2c5543b3073653b601aba26078fdbab682.tar.bz2
upstream-71370d2c5543b3073653b601aba26078fdbab682.zip
target/{sdk,imagebuild}: Fix for symlink-tree
With symlink tree some directories are just symlinked which means IB and SDK end up with a symlink instead of an actual directory; this fixes the missing files by dereferencesing the directories instead of copying the symlinks. Signed-off-by: Daniel Dickinson <lede@cshore.thecshore.com>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 4607535292..77695ee285 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -67,7 +67,7 @@ all: compile
$(BIN_DIR)/$(SDK_NAME).tar.bz2: clean
mkdir -p $(SDK_BUILD_DIR)/dl $(SDK_BUILD_DIR)/package
- $(CP) $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
+ $(CP) -L $(INCLUDE_DIR) $(SCRIPT_DIR) $(TOPDIR)/docs $(SDK_BUILD_DIR)/
$(TAR) -cf - -C $(TOPDIR) \
`cd $(TOPDIR); find $(KDIR_BASE) -name \*.ko` \
`cd $(TOPDIR); find $(KDIR_BASE)/firmware/ -newer $(KDIR_BASE)/firmware/Makefile \