aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 21:51:14 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-14 21:56:29 +0100
commit4894a3ff2870438cf812d88704c92c8d997a69db (patch)
treef2f22934b7f80503e0865d436e4b4f30ca2c11bf /target/sdk
parentf118be07126e88f2fd393909675d815e0b0fd315 (diff)
downloadupstream-4894a3ff2870438cf812d88704c92c8d997a69db.tar.gz
upstream-4894a3ff2870438cf812d88704c92c8d997a69db.tar.bz2
upstream-4894a3ff2870438cf812d88704c92c8d997a69db.zip
target: fix copying of licenses for SDK/toolchain
The SDK and target/toolchain copy the license file into their directories. During the rename/move from LICENSE to a LICENSES folder, this has not been updated. Update it now, and include the new COPYING file. While at it, improve formatting/indent. Fixes: 882e3014610b ("LICENSES: include all used licenses in LICENSES directory") Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d7e10a9bd8..0606621192 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -130,7 +130,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
$(SDK_BUILD_DIR)/target/linux/*/patches*
./convert-config.pl $(TOPDIR)/.config > $(SDK_BUILD_DIR)/Config-build.in
$(CP) -L \
- $(TOPDIR)/LICENSE \
+ $(TOPDIR)/LICENSES \
+ $(TOPDIR)/COPYING \
$(TOPDIR)/rules.mk \
./files/Config.in \
./files/Makefile \