aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-08-08 21:16:02 +0200
committerPetr Štetiar <ynezz@true.cz>2019-08-12 10:04:50 +0200
commit200f2666fb1c8d9d128824dc5586e0e66386971f (patch)
tree8344335456c0a79dfea092be51ed23233f709538 /target/sdk
parent0891358e4b71ff74226d5b8378bfb3c0cb7e666c (diff)
downloadupstream-200f2666fb1c8d9d128824dc5586e0e66386971f.tar.gz
upstream-200f2666fb1c8d9d128824dc5586e0e66386971f.tar.bz2
upstream-200f2666fb1c8d9d128824dc5586e0e66386971f.zip
sdk: fix GCC and Python dangling symlinks
Force prereq again in SDK in order to fix GCC and Python dangling symlinks: staging_dir/host/bin/g++ -> /builder/ath79_generic/ccache_cxx.sh staging_dir/host/bin/gcc -> /builder/ath79_generic/ccache_cc.sh staging_dir/host/bin/python -> /usr/bin/python3.5 staging_dir/host/bin/python3 -> /usr/bin/python3.5 Ref: FS#2424 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 0bed666d21..2badc31429 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -144,7 +144,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
-rm -rf \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/ccache \
$(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/ccache \
- $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache \
+ $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/.prereq-build
-rm -f $(SDK_BUILD_DIR)/feeds.conf.default
$(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)