aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-17 21:50:31 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-17 21:50:31 +0200
commit0f6f518e7aff35e2aad140755f49962c9266820a (patch)
tree5b46df9063a91d6b0b1e00986f8c573045a00d58 /target/sdk
parente88528683487aaf23a9b9a0b2c68009352ea029a (diff)
downloadupstream-0f6f518e7aff35e2aad140755f49962c9266820a.tar.gz
upstream-0f6f518e7aff35e2aad140755f49962c9266820a.tar.bz2
upstream-0f6f518e7aff35e2aad140755f49962c9266820a.zip
sdk: fix generation of base feed url
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/sdk')
-rw-r--r--target/sdk/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index 857a6b76f5..0246afbb87 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -37,7 +37,7 @@ SDK_DIRS = \
BASE_FEED:=$(shell git config --get remote.origin.url 2>/dev/null | sed -ne 's/^/src-git base /p')
BASE_FEED:=$(if $(BASE_FEED),$(BASE_FEED),$(shell cd $(TOPDIR); LC_ALL=C git svn info 2>/dev/null | sed -ne 's/^URL: /src-gitsvn base /p'))
BASE_FEED:=$(if $(BASE_FEED),$(BASE_FEED),$(shell cd $(TOPDIR); LC_ALL=C svn info 2>/dev/null | sed -ne 's/^URL: /src-svn base /p'))
-BASE_FEED:=$(if $(BASE_FEED),$(BASE_FEED),src-git base https://git.openwrt.org/$(filter-out unknown/ r%/,$(subst $(space),.,$(wordlist 1,2,$(subst .,$(space),$(VERSION_NUMBER))))/)openwrt.git)
+BASE_FEED:=$(if $(BASE_FEED),$(BASE_FEED),src-git base https://git.lede-project.org/source.git$(filter-out ;master,;$(shell git rev-parse --abbrev-ref HEAD)))
KDIR_BASE = $(patsubst $(TOPDIR)/%,%,$(LINUX_DIR))