aboutsummaryrefslogtreecommitdiffstats
path: root/target/sdk/Makefile
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-13 13:46:43 -1000
committerMatthias Schiffer <mschiffer@universe-factory.net>2020-08-23 18:55:49 +0200
commit8c9a7881729d82afefc74a8c6e552b20b722b011 (patch)
tree007f30edd255131b26d1366df37c59aa5d39ea17 /target/sdk/Makefile
parent1cf842dd136ceb9a1e1a61d4d4caa3b3a46c0c1b (diff)
downloadupstream-8c9a7881729d82afefc74a8c6e552b20b722b011.tar.gz
upstream-8c9a7881729d82afefc74a8c6e552b20b722b011.tar.bz2
upstream-8c9a7881729d82afefc74a8c6e552b20b722b011.zip
build: SDK/IB reproducible and faster compression
Both IB and SDK now use the same logic for packing. This commit add reproducible multithread compression to the SDK and corrects the file mtime for both. Previously all files where just copied over from the build system, generating random mtimes. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'target/sdk/Makefile')
-rw-r--r--target/sdk/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/sdk/Makefile b/target/sdk/Makefile
index d3552b47eb..022a791ebf 100644
--- a/target/sdk/Makefile
+++ b/target/sdk/Makefile
@@ -152,7 +152,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf
-make -C $(SDK_BUILD_DIR)/scripts/config clean
(cd $(BUILD_DIR); \
- tar -I 'xz -7e' -cf $@ $(SDK_NAME); \
+ tar -I '$(STAGING_DIR_HOST)/bin/xz -7e -T$(if $(filter 1,$(NPROC)),2,0)' -cf $@ $(SDK_NAME) \
+ --mtime="$(shell date --date=@$(SOURCE_DATE_EPOCH))"; \
)
download: