aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-04-10 15:19:52 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-04-10 15:27:39 +0200
commitd3f96fedecce9049f40fca82e20bbc93f44dcd92 (patch)
treeec47ac51af2c400150348b36a02f65afcc359b45 /target/linux
parentf8f6fa11c0410b3486494443739220244d2e9962 (diff)
downloadupstream-d3f96fedecce9049f40fca82e20bbc93f44dcd92.tar.gz
upstream-d3f96fedecce9049f40fca82e20bbc93f44dcd92.tar.bz2
upstream-d3f96fedecce9049f40fca82e20bbc93f44dcd92.zip
ar71xx: increase kernel partition size for UniFi AP Pro and Outdoor+, enable devices again
Tested on UAP Outdoor+. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index 478ac3ea8b..d5e3aa5860 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -258,9 +258,9 @@ TARGET_DEVICES += ubnt-ls-sr71
define Device/ubnt-uap-pro
DEVICE_TITLE := Ubiquiti UAP Pro
- KERNEL_SIZE := 1536k
+ KERNEL_SIZE := 1792k
IMAGE_SIZE := 15744k
- MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1536k(kernel),14208k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1792k(kernel),13952k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
UBNT_TYPE := BZ
UBNT_CHIP := ar934x
BOARDNAME := UAP-PRO
@@ -270,6 +270,7 @@ define Device/ubnt-uap-pro
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage2
endef
+TARGET_DEVICES += ubnt-uap-pro
define Device/ubnt-unifi-outdoor-plus
$(Device/ubnt-uap-pro)
@@ -278,3 +279,4 @@ define Device/ubnt-unifi-outdoor-plus
BOARDNAME := UBNT-UOP
DEVICE_PROFILE := UBNT
endef
+TARGET_DEVICES += ubnt-unifi-outdoor-plus