aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-11-18 09:32:36 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-11-18 09:32:36 +0000
commitd325e622d2e257d42b65585c4acccb9a89814127 (patch)
treebe008ea38223ad7fb1a2311650afd1402456c13d /target/linux
parentc3174179b73e49e9ce32740d0bc65d138b959ada (diff)
downloadupstream-d325e622d2e257d42b65585c4acccb9a89814127.tar.gz
upstream-d325e622d2e257d42b65585c4acccb9a89814127.tar.bz2
upstream-d325e622d2e257d42b65585c4acccb9a89814127.zip
scripts/om-fwupgradecfg-gen.sh: add support for the MR600
Signed-off-by: Marek Lindner <lindner_marek@yahoo.de> Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 34233
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index d3d483d88f..e212348509 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -681,12 +681,13 @@ endif
define Image/Build/OpenMesh
$(call MkuImageLzma,$(2))
-sh $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" \
+ "$(4)" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" \
"$(KDIR)/root.$(1)"
-sh $(TOPDIR)/scripts/combined-ext-image.sh \
"$(4)" "$(call factoryname,$(1),$(2))" \
- "$(BUILD_DIR)/om2p-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(BUILD_DIR)/fwupgrade.cfg-$(4)" "fwupgrade.cfg" \
"$(KDIR_TMP)/vmlinux-$(2).uImage" "kernel" \
"$(KDIR)/root.$(1)" "rootfs"
endef