aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-06-27 12:27:27 +0900
committerDaniel Golle <daniel@makrotopia.org>2019-07-17 14:45:18 +0200
commitcda123fe69fd4a94a3b0e8c5c1f5d35c81e36c99 (patch)
treee2db89e02c42a807119440329afab1406c6f0e2f /target/linux
parent16ac5c4fbd183398d6a1595f6c87fd85c8668b33 (diff)
downloadupstream-cda123fe69fd4a94a3b0e8c5c1f5d35c81e36c99.tar.gz
upstream-cda123fe69fd4a94a3b0e8c5c1f5d35c81e36c99.tar.bz2
upstream-cda123fe69fd4a94a3b0e8c5c1f5d35c81e36c99.zip
ramips: add MT7615 wireless support for ELECOM WRC-1167GHBK2-S
ELECOM WRC-1167GHBK2-S has a MediaTek MT7615D chip for 2.4/5 GHz wireless. A driver package for MT7615 chip is added to OpenWrt in a0e5ca4f3523b9eef96bff32e45f6fa8275b982f, so add preliminary MT7615 chip support for WRC-1167GHBK2-S. Note: Currently, DBDC mode for MT7615 is not supported in mt76 driver. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts15
-rw-r--r--target/linux/ramips/image/mt7621.mk1
2 files changed, 12 insertions, 4 deletions
diff --git a/target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts b/target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts
index 3a6eb7cec8..cf5c9a2d24 100644
--- a/target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts
+++ b/target/linux/ramips/dts/mt7621_elecom_wrc-1167ghbk2-s.dts
@@ -26,6 +26,7 @@
wlan2g {
label = "wrc-1167ghbk2-s:white:wlan2g";
gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0radio";
};
wlan5g {
@@ -139,10 +140,16 @@
&pcie {
status = "okay";
- /*
- * WRC-1167GHBK2-S has MT7615D for 2.4/5 GHz wifi,
- * but it's not supported in OpenWrt.
- */
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ mtd-mac-address = <&factory 0xe000>;
+ mtd-mac-address-increment = <1>;
+ };
};
&xhci {
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e2928c80ce..a48aedd661 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -181,6 +181,7 @@ define Device/elecom_wrc-1167ghbk2-s
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) |\
elecom-wrc-factory WRC-1167GHBK2-S 0.00
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s