aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMichal Cieslakiewicz <michal.cieslakiewicz@wp.pl>2019-10-30 12:32:21 +0100
committerJohn Crispin <john@phrozen.org>2019-11-02 20:51:56 +0100
commitcd87272eb241b1ea7955c1631ad2bb8d38e9fae9 (patch)
tree6b92ef0a989c57c785d9adf6146781904cd4c667 /target/linux
parent87f9292300cf56ad17f44363ced213c59a95ef44 (diff)
downloadupstream-cd87272eb241b1ea7955c1631ad2bb8d38e9fae9.tar.gz
upstream-cd87272eb241b1ea7955c1631ad2bb8d38e9fae9.tar.bz2
upstream-cd87272eb241b1ea7955c1631ad2bb8d38e9fae9.zip
ath79: add support for Netgear WNDR4300
This patch adds ath79 support for Netgear WNDR4300. Router was previously supported by ar71xx target only. Note: device requires 'ar934x-nand' driver in kernel. Specification ============= * Description: Netgear WNDR4300 * Loader: U-boot * SOC: Atheros AR9344 (560 MHz) * RAM: 128 MiB * Flash: 128 MiB (NAND) - U-boot binary: 256 KiB - U-boot environment: 256 KiB - ART: 256 KiB - POT: 512 KiB - Language: 2 MiB - Config: 512 KiB - Traffic Meter: 3 MiB - Firmware: 25 MiB - ART Backup: 256 KiB - Reserved: 96 MiB * Ethernet: 5 x 10/100/1000 (4 x LAN, 1 x WAN) (AR8327) * Wireless: - 2.4 GHz b/g/n (internal) - 5 GHz a/n (AR9580) * USB: yes, 1 x USB 2.0 * Buttons: - Reset - WiFi (rfkill) - WPS * LEDs: - Power (amber/green) - WAN (amber/green) - WLAN 2G (green) - WLAN 5G (blue) - 4 x LAN (amber/green) - USB (green) - WPS (amber/green) * UART: 4-pin connector JP1, 3.3V (Vcc, TX, RX, GND), 115200 8N1 * Power supply: DC 12V 2.5A * MAC addresses: LAN=WLAN2G on case label, WAN +1, WLAN5G +2 Installation ============ * TFTP recovery * TFTP via U-boot prompt * sysupgrade * Web interface Note about partitioning: firmware partition offset (0x6c0000) is hardcoded into vendor's u-boot, so this partition cannot be moved and resized to include Netgear-specific flash areas (pot, language, config, traffic_meter) not used by OpenWrt. Test build configuration ======================== CONFIG_TARGET_ath79=y CONFIG_TARGET_ath79_nand=y CONFIG_TARGET_ath79_nand_DEVICE_netgear_wndr4300=y CONFIG_ALL_KMODS=y CONFIG_DEVEL=y CONFIG_CCACHE=y CONFIG_COLLECT_KERNEL_DEBUG=y CONFIG_IMAGEOPT=y Signed-off-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ath79/image/Makefile1
-rw-r--r--target/linux/ath79/image/nand-netgear.mk34
2 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/ath79/image/Makefile b/target/linux/ath79/image/Makefile
index 24768ef5e0..b6ac83cdc1 100644
--- a/target/linux/ath79/image/Makefile
+++ b/target/linux/ath79/image/Makefile
@@ -77,6 +77,7 @@ include ./generic-ubnt.mk
endif
ifeq ($(SUBTARGET),nand)
include ./nand.mk
+include ./nand-netgear.mk
endif
ifeq ($(SUBTARGET),tiny)
include ./tiny.mk
diff --git a/target/linux/ath79/image/nand-netgear.mk b/target/linux/ath79/image/nand-netgear.mk
new file mode 100644
index 0000000000..b25e6ec66c
--- /dev/null
+++ b/target/linux/ath79/image/nand-netgear.mk
@@ -0,0 +1,34 @@
+include ./common-netgear.mk # for netgear-uImage
+
+# (pad-offset 129 = 2 * uimage_header + 0xff)
+define Device/netgear_ath79_nand
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ledtrig-usbport
+ KERNEL_SIZE := 2048k
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ IMAGE_SIZE := 25600k
+ KERNEL := kernel-bin | append-dtb | lzma -d20 | \
+ pad-offset $$(KERNEL_SIZE) 129 | \
+ netgear-uImage lzma | append-string -e '\xff' | \
+ append-uImage-fakehdr filesystem $$(NETGEAR_KERNEL_MAGIC)
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma -d20 | \
+ netgear-uImage lzma
+ IMAGES := ubi-sysupgrade.bin ubi-factory.img
+ IMAGE/ubi-factory.img := append-kernel | append-ubi | netgear-dni | \
+ check-size $$$$(IMAGE_SIZE)
+ IMAGE/ubi-sysupgrade.bin := sysupgrade-tar | append-metadata | \
+ check-size $$$$(IMAGE_SIZE)
+ UBINIZE_OPTS := -E 5
+endef
+
+define Device/netgear_wndr4300
+ ATH_SOC := ar9344
+ DEVICE_MODEL := WNDR4300
+ NETGEAR_KERNEL_MAGIC := 0x33373033
+ NETGEAR_BOARD_ID := WNDR4300
+ NETGEAR_HW_ID := 29763948+0+128+128+2x2+3x3
+ SUPPORTED_DEVICES += wndr4300
+ $(Device/netgear_ath79_nand)
+endef
+TARGET_DEVICES += netgear_wndr4300