aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2017-10-27 00:23:17 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-11-14 22:36:46 +0100
commitca6002c0efab2e847be91b13d558e5c38184b50a (patch)
treeaa185aa4313da1b79d19e0350d9f95dfad151129 /target/linux
parent3f96e57aed69fcd88a8d4f06bbf97688f67ca343 (diff)
downloadupstream-ca6002c0efab2e847be91b13d558e5c38184b50a.tar.gz
upstream-ca6002c0efab2e847be91b13d558e5c38184b50a.tar.bz2
upstream-ca6002c0efab2e847be91b13d558e5c38184b50a.zip
ar71xx: increase kernel partition size for some TP-Link boards
This patch increases kernel partition size and re-enables image generation for below TP-Link boards: - archer-c58-v1 - archer-c60-v1 - tl-wr902ac-v1 - tl-wr942n-v1 Signed-off-by: Henryk Heisig <hyniu@o2.pl> [commit message and title reworded] Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/tp-link.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index b7689c2741..2dedf3564b 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -123,7 +123,7 @@ define Device/archer-c58-v1
TPLINK_BOARD_ID := ARCHER-C58-V1
DEVICE_PROFILE := ARCHERC58V1
IMAGE_SIZE := 7936k
- MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+ MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,7936k(firmware),64k(tplink)ro,64k(art)ro
SUPPORTED_DEVICES := archer-c58-v1
endef
@@ -147,10 +147,10 @@ define Device/archer-c60-v1
TPLINK_BOARD_ID := ARCHER-C60-V1
DEVICE_PROFILE := ARCHERC60V1
IMAGE_SIZE := 7936k
- MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,1344k(kernel),6592k(rootfs),64k(tplink)ro,64k(art)ro,7936k@0x20000(firmware)
+ MTDPARTS := spi0.0:64k(u-boot)ro,64k(mac)ro,7936k(firmware),64k(tplink)ro,64k(art)ro
SUPPORTED_DEVICES := archer-c60-v1
endef
-TARGET_DEVICES += archer-c25-v1 archer-c59-v1
+TARGET_DEVICES += archer-c25-v1 archer-c58-v1 archer-c59-v1 archer-c60-v1
define Device/archer-c5-v1
$(Device/tplink-16mlzma)
@@ -1043,6 +1043,7 @@ define Device/tl-wr902ac-v1
append-metadata | check-size $$$$(IMAGE_SIZE)
MTDPARTS := spi0.0:128k(u-boot)ro,7360k(firmware),640k(tplink)ro,64k(art)ro
endef
+TARGET_DEVICES += tl-wr902ac-v1
define Device/tl-wr940n-v4
$(Device/tplink-4mlzma)
@@ -1114,7 +1115,7 @@ define Device/tl-wr942n-v1
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
- MTDPARTS := spi0.0:128k(u-boot)ro,1344k(kernel),13120k(rootfs),64k(product-info)ro,64k(partition-table)ro,256k(oem-config)ro,1344k(oem-vars)ro,64k(ART)ro,14464k@0x20000(firmware)
+ MTDPARTS := spi0.0:128k(u-boot)ro,14464k(firmware),64k(product-info)ro,64k(partition-table)ro,256k(oem-config)ro,1344k(oem-vars)ro,64k(ART)ro
SUPPORTED_DEVICES := tl-wr942n-v1
endef
-TARGET_DEVICES += tl-wr940n-v4 tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn
+TARGET_DEVICES += tl-wr940n-v4 tl-wr941nd-v2 tl-wr941nd-v3 tl-wr941nd-v4 tl-wr941nd-v5 tl-wr941nd-v6 tl-wr941nd-v6-cn tl-wr942n-v1