aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorKristian Evensen <kristian.evensen@gmail.com>2017-03-02 13:44:02 +0100
committerJohn Crispin <john@phrozen.org>2017-03-11 08:36:52 +0100
commitb11c51916cb9b9d12faea3ab9e00c05fceca4a42 (patch)
tree4cca6708baa53c847e8cee3ca6f3b43f61d4aa71 /target/linux
parent0ad82375cd0e85d78f9b23d28da3866741041a5b (diff)
downloadupstream-b11c51916cb9b9d12faea3ab9e00c05fceca4a42.tar.gz
upstream-b11c51916cb9b9d12faea3ab9e00c05fceca4a42.tar.bz2
upstream-b11c51916cb9b9d12faea3ab9e00c05fceca4a42.zip
ramips: Improve Sanlinking D240 config
* The left most mini-PCIe slot (the one attached to SIM2) can be power-cycled by setting GPIO 0 to high/low. * The D240 only needs the MT76x2 module, so update makefile to reflect this. Note that until the default mt7620 target is updated, then kmod-mt76 (and thus kmod-mt7603) will be selected by default. v2->v3: * Indentation error. v1->v2: * Rename gpio and remove redundant comment (thanks Piotr Dymacz) Signed-off-by: Kristian Evensen <kristian.evensen@gmail.com>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/D240.dts11
-rw-r--r--target/linux/ramips/image/mt7620.mk2
2 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/D240.dts b/target/linux/ramips/dts/D240.dts
index ef45d38e61..46d014126d 100644
--- a/target/linux/ramips/dts/D240.dts
+++ b/target/linux/ramips/dts/D240.dts
@@ -46,6 +46,17 @@
bootargs = "console=ttyS0,115200";
};
+ gpio-export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ power_mpcie2 {
+ gpio-export,name = "power_mpcie2";
+ gpio-export,output = <GPIO_ACTIVE_LOW>;
+ gpios = <&gpio0 0 GPIO_ACTIVE_HIGH>;
+ };
+ };
+
gpio-leds {
compatible = "gpio-leds";
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index ece1539714..3ecd4ba3a1 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -471,6 +471,6 @@ define Device/d240
DTS := D240
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_TITLE := Sanlinking Technologies D240
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76-core kmod-mt76x2 kmod-sdhci-mt7620
endef
TARGET_DEVICES += d240