aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-10-12 00:49:15 +0200
committerPetr Štetiar <ynezz@true.cz>2020-12-22 19:11:50 +0100
commit98b86296e67dd2b467212fe1a577656e6d3725da (patch)
treed31352bc667bc9b632830bd94503f023d520e820 /target/linux
parent4d0c442a0a2fdc84ff0dc2c7106455d15c03defe (diff)
downloadupstream-98b86296e67dd2b467212fe1a577656e6d3725da.tar.gz
upstream-98b86296e67dd2b467212fe1a577656e6d3725da.tar.bz2
upstream-98b86296e67dd2b467212fe1a577656e6d3725da.zip
ipq806x: add support for ASRock G10
The ASRock G10 is a 2.4/5 GHz band 11ac "Gaming" router, based on Qualcomm IPQ8064. Specifications: SoC: Qualcomm IPQ8064 CPU: Dual-Core A15 @ (384 - 1,400 MHz, 2C2T) DRAM: 512 MiB (~467 MiB available) NAND: 128 MB (Micron MT29F1G08ABBEAH4) WLAN0: 4T4R 5 GHz Wlan (QCA9980) WLAN1: 4T4R 2.4 GHz Wlan (QCA9980) ETH: 5x 10/100/1000 Mbps Ethernet (QCA8337) INPUT: Reset Button, WPS 2.4G and WPS 5G Button LEDS: 1 multicolor status LED USB: 2x USB 3.0 Type-A POWER: 12VDC/3A AC Adapter + dedicated Power Switch UART: Setting is 115200-8-N-1. 1x4 .1" unpopulated header on the PCB (J6 - very tiny silkscreen next to TX). Pinout: 1. 3v3 (Square - best skipped!), 2. RX, 3. GND, 4. TX WARNING: The serial port needs a TTL/RS-232 3.3v level converter! (Depending on the serial adapter RX and TX might need to be swapped). Note about the IR-Remote: There's a 8-Bit MCU (SONIX SN8F25E21SG) which is controlling the IR-Remote and is fed by the IR-Photodiode. The SoC can talk to the device via I2C. The vendor's GPL archive comes with the source of the interface driver for this as a (character driver), the main control software is however a blob. Installation Instructions: 1. Download factory image to disk 2. Apply factory image via stock web-gui Back to stock: 1. Login to router via ssh 2. run "asrock_g10_back_to_factory" script from /sbin Notes: - If something goes wrong durring sysupgrade, router will go back to factory image. - Asrock G10 uses partition layout from smem. So partition layout can be normal or alternate. - 900-arm-add-cmdline-override.patch was copied from 102-powerpc-add-cmdline-override.patch from powerpc target. Knowledge about BOOTCONFIG partition was based on user "jmomo" post from old OpenWrt forum (Post #50): https://forum.archive.openwrt.org/viewtopic.php?id=65956&p=2 Signed-off-by: Christian Lamparter <chunkeey@gmail.com> [bump to 5.4, add factory image, fix sysupgrade, convert partition layout to smem, remove ipq-wifi-asrock-g10 and use ART, minor fixes] Co-Authored-by: Pawel Dembicki <paweldembicki@gmail.com> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Tested-by: Lukasz Ostapiuk <palibrzuch@gmail.com>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/board.d/02_network9
-rw-r--r--target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata6
-rwxr-xr-xtarget/linux/ipq806x/base-files/etc/init.d/bootcount8
-rw-r--r--target/linux/ipq806x/base-files/lib/preinit/05_set_iface_mac_ipq806x.sh14
-rw-r--r--target/linux/ipq806x/base-files/lib/upgrade/asrock.sh55
-rw-r--r--target/linux/ipq806x/base-files/lib/upgrade/platform.sh4
-rwxr-xr-xtarget/linux/ipq806x/base-files/sbin/asrock_g10_back_to_factory16
-rw-r--r--target/linux/ipq806x/config-5.41
-rw-r--r--target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-g10.dts242
-rw-r--r--target/linux/ipq806x/image/Makefile24
-rw-r--r--target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch3
-rw-r--r--target/linux/ipq806x/patches-5.4/900-arm-add-cmdline-override.patch37
-rw-r--r--target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch4
13 files changed, 416 insertions, 7 deletions
diff --git a/target/linux/ipq806x/base-files/etc/board.d/02_network b/target/linux/ipq806x/base-files/etc/board.d/02_network
index 3f9d96881d..eecf81a8cd 100755
--- a/target/linux/ipq806x/base-files/etc/board.d/02_network
+++ b/target/linux/ipq806x/base-files/etc/board.d/02_network
@@ -12,6 +12,11 @@ board_config_update
board=$(board_name)
case "$board" in
+asrock,g10 |\
+nec,wg2600hp)
+ ucidef_add_switch "switch0" \
+ "2:lan" "3:lan" "4:lan" "5:lan" "6@eth1" "1:wan" "0@eth0"
+ ;;
buffalo,wxr-2533dhp |\
compex,wpq864 |\
netgear,d7800 |\
@@ -41,10 +46,6 @@ linksys,ea8500)
ucidef_set_interface_macaddr "lan" "$hw_mac_addr"
ucidef_set_interface_macaddr "wan" "$hw_mac_addr"
;;
-nec,wg2600hp)
- ucidef_add_switch "switch0" \
- "2:lan" "3:lan" "4:lan" "5:lan" "6@eth1" "1:wan" "0@eth0"
- ;;
netgear,r7800 |\
tplink,c2600)
ucidef_add_switch "switch0" \
diff --git a/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 74ad00c5ce..a22af9b676 100644
--- a/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -9,6 +9,9 @@ board=$(board_name)
case "$FIRMWARE" in
"ath10k/pre-cal-pci-0000:01:00.0.bin")
case $board in
+ asrock,g10)
+ caldata_extract "0:ART" 0x1000 0x2f20
+ ;;
buffalo,wxr-2533dhp)
caldata_extract "ART" 0x1000 0x2f20
ath10k_patch_mac $(mtd_get_mac_binary ART 0x1e)
@@ -47,6 +50,9 @@ case "$FIRMWARE" in
;;
"ath10k/pre-cal-pci-0001:01:00.0.bin")
case $board in
+ asrock,g10)
+ caldata_extract "0:ART" 0x5000 0x2f20
+ ;;
buffalo,wxr-2533dhp)
caldata_extract "ART" 0x5000 0x2f20
ath10k_patch_mac $(mtd_get_mac_binary ART 0x18)
diff --git a/target/linux/ipq806x/base-files/etc/init.d/bootcount b/target/linux/ipq806x/base-files/etc/init.d/bootcount
index 77965e647b..7a54c34dba 100755
--- a/target/linux/ipq806x/base-files/etc/init.d/bootcount
+++ b/target/linux/ipq806x/base-files/etc/init.d/bootcount
@@ -2,8 +2,16 @@
START=99
+. /lib/upgrade/asrock.sh
+
boot() {
case $(board_name) in
+ asrock,g10)
+ asrock_bootconfig_mangle "bootcheck"
+ if [ $? -eq 0 ]; then
+ reboot
+ fi
+ ;;
edgecore,ecw5410)
fw_setenv bootcount 0
;;
diff --git a/target/linux/ipq806x/base-files/lib/preinit/05_set_iface_mac_ipq806x.sh b/target/linux/ipq806x/base-files/lib/preinit/05_set_iface_mac_ipq806x.sh
new file mode 100644
index 0000000000..ca8d0b1555
--- /dev/null
+++ b/target/linux/ipq806x/base-files/lib/preinit/05_set_iface_mac_ipq806x.sh
@@ -0,0 +1,14 @@
+. /lib/functions.sh
+
+preinit_set_mac_address() {
+ case $(board_name) in
+ asrock,g10)
+ lan_mac=$(mtd_get_mac_ascii hwconfig HW.LAN.MAC.Address)
+ wan_mac=$(mtd_get_mac_ascii hwconfig HW.WAN.MAC.Address)
+ ip link set dev eth0 address "${lan_mac}"
+ ip link set dev eth1 address "${wan_mac}"
+ ;;
+ esac
+}
+
+boot_hook_add preinit_main preinit_set_mac_address
diff --git a/target/linux/ipq806x/base-files/lib/upgrade/asrock.sh b/target/linux/ipq806x/base-files/lib/upgrade/asrock.sh
new file mode 100644
index 0000000000..71cac3faac
--- /dev/null
+++ b/target/linux/ipq806x/base-files/lib/upgrade/asrock.sh
@@ -0,0 +1,55 @@
+. /lib/functions.sh
+
+
+asrock_bootconfig_mangle() {
+ local mtdnum="$( find_mtd_index 0:BOOTCONFIG )"
+
+ if [ -z "$mtdnum" ]; then
+ echo "cannot find bootconfig mtd partition"
+ return 1
+ fi
+ dd if=/dev/mtd$mtdnum of=/tmp/mtd$mtdnum bs=1k
+
+ local partition_byte="$(dd if=/tmp/mtd$mtdnum bs=1 skip=52 count=1)"
+ local upgrade_byte="$(dd if=/tmp/mtd$mtdnum bs=1 skip=4 count=1)"
+
+ if [ $1 = "bootcheck" ]; then
+ if [ ! -s $upgrade_byte ]; then
+ dd if=/dev/mtd$mtdnum of=/tmp/mtd$mtdnum bs=1k
+ printf '\x00' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=4
+ printf '\x00' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=56
+ else
+ return 1
+ fi
+ elif [ $1 = "sysupgrade" ]; then
+ printf '\x01' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=4
+ printf '\x01' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=56
+ fi
+
+ if [ -s $partition_byte ]; then
+ printf '\x01' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=52
+ else
+ printf '\x00' | dd of=/tmp/mtd$mtdnum conv=notrunc bs=1 seek=52
+ fi
+
+ mtd write /tmp/mtd$mtdnum /dev/mtd$mtdnum
+ return 0
+}
+
+asrock_upgrade_prepare() {
+ local ubidev="$( nand_find_ubi ubi )"
+
+ #Set upgrade flag. If something goes wrong, router will boot with
+ #factory firmware.
+ asrock_bootconfig_mangle 'sysupgrade'
+
+ if [ $? -ne 0 ]; then
+ echo "cannot find bootconfig mtd partition"
+ exit 1
+ fi
+
+ # Just delete these partitions if present and use
+ # OpenWrt's standard names for those.
+ ubirmvol /dev/$ubidev -N ubi_rootfs &> /dev/null || true
+ ubirmvol /dev/$ubidev -N ubi_rootfs_data &> /dev/null || true
+}
diff --git a/target/linux/ipq806x/base-files/lib/upgrade/platform.sh b/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
index f61e8ee878..f5d6c5d55d 100644
--- a/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ipq806x/base-files/lib/upgrade/platform.sh
@@ -10,6 +10,10 @@ platform_check_image() {
platform_do_upgrade() {
case "$(board_name)" in
+ asrock,g10)
+ asrock_upgrade_prepare
+ nand_do_upgrade "$1"
+ ;;
buffalo,wxr-2533dhp)
buffalo_upgrade_prepare_ubi
CI_ROOTPART="ubi_rootfs"
diff --git a/target/linux/ipq806x/base-files/sbin/asrock_g10_back_to_factory b/target/linux/ipq806x/base-files/sbin/asrock_g10_back_to_factory
new file mode 100755
index 0000000000..55aa91eab6
--- /dev/null
+++ b/target/linux/ipq806x/base-files/sbin/asrock_g10_back_to_factory
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+. /lib/upgrade/asrock.sh
+
+case $(board_name) in
+asrock,g10)
+ asrock_bootconfig_mangle "factory"
+ if [ $? -eq 0 ]; then
+ reboot
+ fi
+ ;;
+*)
+ echo "Unsupported hardware."
+ ;;
+esac
+
diff --git a/target/linux/ipq806x/config-5.4 b/target/linux/ipq806x/config-5.4
index 2c8e6bbbb0..e6160bd455 100644
--- a/target/linux/ipq806x/config-5.4
+++ b/target/linux/ipq806x/config-5.4
@@ -78,6 +78,7 @@ CONFIG_CC_HAS_KASAN_GENERIC=y
CONFIG_CLKDEV_LOOKUP=y
CONFIG_CLKSRC_QCOM=y
CONFIG_CLONE_BACKWARDS=y
+CONFIG_CMDLINE_OVERRIDE=y
CONFIG_COMMON_CLK=y
CONFIG_COMMON_CLK_QCOM=y
CONFIG_COMPAT_32BIT_TIME=y
diff --git a/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-g10.dts b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-g10.dts
new file mode 100644
index 0000000000..15ed5b4773
--- /dev/null
+++ b/target/linux/ipq806x/files-5.4/arch/arm/boot/dts/qcom-ipq8064-g10.dts
@@ -0,0 +1,242 @@
+// SPDX-License-Identifier: GPL-2.0
+#include "qcom-ipq8064-v2.0.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+ compatible = "asrock,g10", "qcom,ipq8064";
+ model = "ASRock G10";
+
+ aliases {
+ ethernet0 = &gmac1;
+ ethernet1 = &gmac0;
+
+ led-boot = &led_status_blue;
+ led-failsafe = &led_status_amber;
+ led-running = &led_status_blue;
+ led-upgrade = &led_status_amber;
+ };
+
+ chosen {
+ bootargs-override = "console=ttyMSM0,115200n8";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ pinctrl-0 = <&led_pins>;
+ pinctrl-names = "default";
+
+ /*
+ * this is a bit misleading. Because there are about seven
+ * multicolor LEDs connected all wired together in parallel.
+ */
+
+ status_yellow {
+ label = "yellow:status";
+ gpios = <&qcom_pinmux 8 GPIO_ACTIVE_HIGH>;
+ };
+
+ led_status_amber: status_amber {
+ label = "amber:status";
+ gpios = <&qcom_pinmux 7 GPIO_ACTIVE_HIGH>;
+ };
+
+ led_status_blue: status_blue {
+ label = "blue:status";
+ gpios = <&qcom_pinmux 9 GPIO_ACTIVE_HIGH>;
+ };
+
+ /*
+ * LED is declared in vendors boardfile but it's not
+ * working and the manual doesn't mention anything
+ * about the LED being white.
+
+ status_white {
+ label = "white:status";
+ gpios = <&qcom_pinmux 26 GPIO_ACTIVE_HIGH>;
+ };
+ */
+ };
+
+ i2c-gpio {
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ compatible = "i2c-gpio";
+ gpios = <&qcom_pinmux 53 GPIO_ACTIVE_HIGH>, /* sda */
+ <&qcom_pinmux 54 GPIO_ACTIVE_HIGH>; /* scl */
+ i2c-gpio,delay-us = <5>;
+ i2c-gpio,scl-output-only;
+
+ mcu@50 {
+ reg = <0x50>;
+ compatible = "sonix,sn8f25e21";
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ pinctrl-0 = <&button_pins>;
+ pinctrl-names = "default";
+
+ ir-remote {
+ label = "ir-remote";
+ gpios = <&qcom_pinmux 15 GPIO_ACTIVE_LOW>;
+ linux,code = <BTN_0>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&qcom_pinmux 16 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps5g {
+ label = "wps5g";
+ gpios = <&qcom_pinmux 64 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ wps2g {
+ label = "wps2g";
+ gpios = <&qcom_pinmux 65 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+};
+
+&adm_dma {
+ status = "okay";
+};
+
+&gmac1 {
+ status = "okay";
+
+ pinctrl-0 = <&rgmii2_pins>;
+ pinctrl-names = "default";
+
+ phy-mode = "rgmii";
+ qcom,id = <1>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
+
+&gmac2 {
+ status = "okay";
+
+ phy-mode = "sgmii";
+ qcom,id = <2>;
+
+ fixed-link {
+ speed = <1000>;
+ full-duplex;
+ };
+};
+
+&gsbi4_serial {
+ pinctrl-0 = <&uart0_pins>;
+ pinctrl-names = "default";
+};
+
+&mdio0 {
+ status = "okay";
+
+ pinctrl-0 = <&mdio0_pins>;
+ pinctrl-names = "default";
+
+ ethernet-phy@0 {
+ reg = <0>;
+ qca,ar8327-initvals = <
+ 0x00004 0x7600000 /* PAD0_MODE */
+ 0x00008 0x1000000 /* PAD5_MODE */
+ 0x0000c 0x80 /* PAD6_MODE */
+ 0x000e4 0x6a545 /* MAC_POWER_SEL */
+ 0x000e0 0xc74164de /* SGMII_CTRL */
+ 0x0007c 0x4e /* PORT0_STATUS */
+ 0x00094 0x4e /* PORT6_STATUS */
+ >;
+ };
+};
+
+&nand_controller {
+ status = "okay";
+
+ pinctrl-0 = <&nand_pins>;
+ pinctrl-names = "default";
+
+ nand@0 {
+ reg = <0>;
+ compatible = "qcom,nandcs";
+
+ nand-ecc-strength = <4>;
+ nand-bus-width = <8>;
+ nand-ecc-step-size = <512>;
+
+ partitions {
+ compatible = "qcom,smem";
+ };
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&pcie1 {
+ status = "okay";
+};
+
+&qcom_pinmux {
+ led_pins: led_pins {
+ mux {
+ pins = "gpio7", "gpio8", "gpio9", "gpio26";
+ function = "gpio";
+ drive-strength = <2>;
+ bias-pull-up;
+ };
+ };
+
+ button_pins: button_pins {
+ mux {
+ pins = "gpio15", "gpio16", "gpio64", "gpio65";
+ function = "gpio";
+ drive-strength = <2>;
+ bias-pull-up;
+ };
+ };
+
+ uart0_pins: uart0_pins {
+ mux {
+ pins = "gpio10", "gpio11";
+ function = "gsbi4";
+ drive-strength = <10>;
+ bias-disable;
+ };
+ };
+};
+
+&rpm {
+ pinctrl-0 = <&i2c4_pins>;
+ pinctrl-names = "default";
+};
+
+&usb3_0 {
+ status = "okay";
+};
+
+&usb3_1 {
+ status = "okay";
+};
+
+&tcsr {
+ qcom,usb-ctrl-select = <TCSR_USB_SELECT_USB3_DUAL>;
+};
+
+/delete-node/ &pcie2_pins;
+/delete-node/ &pcie2;
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index ec73630ae5..ad7c4b94d2 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -13,6 +13,16 @@ define Build/buffalo-rootfs-cksum
) >> $@
endef
+define Build/edimax-header
+ $(eval edimax_model=$(word 1,$(1)))
+
+ $(STAGING_DIR_HOST)/bin/mkedimaximg \
+ -b -s CSYS -m $(edimax_model) \
+ -f 0x70000 -S 0x1200000 \
+ -i $@ -o $@.new
+ @mv $@.new $@
+endef
+
define Device/Default
PROFILES := Default
KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -82,6 +92,20 @@ define Device/ZyXELImage
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$$(BLOCKSIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
+define Device/asrock_g10
+ $(call Device/FitImage)
+ $(call Device/UbiFit)
+ SOC := qcom-ipq8064
+ DEVICE_VENDOR := ASRock
+ DEVICE_MODEL := G10
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 5332k
+ DEVICE_PACKAGES := kmod-i2c-gpio ath10k-firmware-qca99x0-ct
+ IMAGE/nand-factory.bin := append-ubi | edimax-header RN67
+endef
+TARGET_DEVICES += asrock_g10
+
define Device/buffalo_wxr-2533dhp
$(call Device/LegacyImage)
SOC := qcom-ipq8064
diff --git a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
index 7e15b87e39..6bbf184ac7 100644
--- a/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
+++ b/target/linux/ipq806x/patches-5.4/0069-arm-boot-add-dts-files.patch
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
-@@ -843,6 +843,20 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -843,6 +843,21 @@ dtb-$(CONFIG_ARCH_QCOM) += \
qcom-ipq4019-ap.dk07.1-c1.dtb \
qcom-ipq4019-ap.dk07.1-c2.dtb \
qcom-ipq8064-ap148.dtb \
@@ -20,6 +20,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
+ qcom-ipq8064-ap161.dtb \
+ qcom-ipq8064-ea7500-v1.dtb \
+ qcom-ipq8064-ea8500.dtb \
++ qcom-ipq8064-g10.dtb \
+ qcom-ipq8064-r7500.dtb \
+ qcom-ipq8064-r7500v2.dtb \
+ qcom-ipq8064-wg2600hp.dtb \
diff --git a/target/linux/ipq806x/patches-5.4/900-arm-add-cmdline-override.patch b/target/linux/ipq806x/patches-5.4/900-arm-add-cmdline-override.patch
new file mode 100644
index 0000000000..bb3aa2622c
--- /dev/null
+++ b/target/linux/ipq806x/patches-5.4/900-arm-add-cmdline-override.patch
@@ -0,0 +1,37 @@
+--- a/arch/arm/Kconfig
++++ b/arch/arm/Kconfig
+@@ -1836,6 +1836,14 @@ config ARM_ATAG_DTB_COMPAT_CMDLINE_MANGL
+ Only command line ATAG will be processed, the rest of the ATAGs
+ sent by bootloader will be ignored.
+
++config CMDLINE_OVERRIDE
++ bool "Use alternative cmdline from device tree"
++ help
++ Some bootloaders may have uneditable bootargs. While CMDLINE_FORCE can
++ be used, this is not a good option for kernels that are shared across
++ devices. This setting enables using "chosen/cmdline-override" as the
++ cmdline if it exists in the device tree.
++
+ endchoice
+
+ config CMDLINE
+--- a/drivers/of/fdt.c
++++ b/drivers/of/fdt.c
+@@ -1060,6 +1060,17 @@ int __init early_init_dt_scan_chosen(uns
+ if (p != NULL && l > 0)
+ strlcpy(data, p, min(l, COMMAND_LINE_SIZE));
+
++ /* CONFIG_CMDLINE_OVERRIDE is used to fallback to a different
++ * device tree option of chosen/bootargs-override. This is
++ * helpful on boards where u-boot sets bootargs, and is unable
++ * to be modified.
++ */
++#ifdef CONFIG_CMDLINE_OVERRIDE
++ p = of_get_flat_dt_prop(node, "bootargs-override", &l);
++ if (p != NULL && l > 0)
++ strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
++#endif
++
+ /*
+ * CONFIG_CMDLINE is meant to be a default in case nothing else
+ * managed to set the command line, unless CONFIG_CMDLINE_FORCE
diff --git a/target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch b/target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch
index 3cc032fdd2..b6b1b04765 100644
--- a/target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch
+++ b/target/linux/ipq806x/patches-5.4/997-device_tree_cmdline.patch
@@ -8,5 +8,5 @@
+ if (p != NULL && l > 0)
+ strlcat(data, p, min_t(int, strlen(data) + (int)l, COMMAND_LINE_SIZE));
- /*
- * CONFIG_CMDLINE is meant to be a default in case nothing else
+ /* CONFIG_CMDLINE_OVERRIDE is used to fallback to a different
+ * device tree option of chosen/bootargs-override. This is