aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorAntonio Silverio <menion@gmail.com>2018-10-17 09:18:45 +0200
committerMathias Kresin <dev@kresin.me>2018-12-31 13:28:31 +0100
commit9601d94138de66e4fc9f55a08dfb348cdfcc3181 (patch)
treec3431d8c62e94465203f22f7d21052e5feb446a9 /target/linux
parent98f826fdc0a982bea9eee8f397fdf0d2ef018cab (diff)
downloadupstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.tar.gz
upstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.tar.bz2
upstream-9601d94138de66e4fc9f55a08dfb348cdfcc3181.zip
ath79: add support for TP-Link TL-WR841N/ND v8
CPU: Atheros AR9341 535MHz RAM: 32MB FLASH: 4MiB PORTS: 4 Port 100/10 Switch, 1 Port 100/10 Wan WiFi: Atheros AR9341 2x2:2 bgn LED: Power (static on), LAN (controlled by Switch), WAN, SYS, WiFi, RFKill BTN: WPS, WiFi, Reset Installation: Upload the factory image via the vendor-GUI. Signed-off-by: Antonio Silverio <menion@gmail.com> [resolve merge conflicts, squash commits, fix commit title, remove default default off led properties, mark sysupgrade image compatible with the ar71xx version of the board, drop blank lines from dts] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ath79/dts/ar9341_tplink_tl-wr841-v8.dts164
-rw-r--r--target/linux/ath79/image/tiny-tp-link.mk9
4 files changed, 175 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index cc718b4d96..a9f81cd230 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -97,6 +97,7 @@ tplink,tl-wr941-v4)
;;
tplink,tl-wr740nd-v4|\
tplink,tl-wr741nd-v4|\
+tplink,tl-wr841-v8|\
tplink,tl-wr842n-v2)
ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth0"
ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x04"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index cd786c2b79..1be7a63c85 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -182,6 +182,7 @@ ath79_setup_interfaces()
"0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
;;
tplink,tl-wr740nd-v4|\
+ tplink,tl-wr841-v8|\
tplink,tl-wr842n-v1|\
tplink,tl-wr842n-v2)
ucidef_set_interface_wan "eth0"
diff --git a/target/linux/ath79/dts/ar9341_tplink_tl-wr841-v8.dts b/target/linux/ath79/dts/ar9341_tplink_tl-wr841-v8.dts
new file mode 100644
index 0000000000..ec89be5318
--- /dev/null
+++ b/target/linux/ath79/dts/ar9341_tplink_tl-wr841-v8.dts
@@ -0,0 +1,164 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9341.dtsi"
+
+/ {
+ model = "TP-Link TL-WR841N/ND v8";
+ compatible = "tplink,tl-wr841-v8", "qca,ar9341";
+
+ aliases {
+ serial0 = &uart;
+ led-boot = &system;
+ led-failsafe = &system;
+ led-running = &system;
+ led-upgrade = &system;
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+
+ pinctrl-names = "default";
+ pinctrl-0 = <&jtag_disable_pins>;
+
+ reset {
+ label = "Reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ rfkill {
+ label = "WiFi";
+ linux,code = <KEY_RFKILL>;
+ gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ system: power {
+ label = "tp-link:green:power";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wlan {
+ label = "tp-link:green:wlan";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ qss {
+ label = "tp-link:green:qss";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "tp-link:green:wan";
+ gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+ };
+
+ lan1 {
+ label = "tp-link:green:lan1";
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ };
+
+ lan2 {
+ label = "tp-link:green:lan2";
+ gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+ };
+
+ lan3 {
+ label = "tp-link:green:lan3";
+ gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+ };
+
+ lan4 {
+ label = "tp-link:green:lan4";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&ref {
+ clock-frequency = <25000000>;
+};
+
+&uart {
+ status = "okay";
+};
+
+&gpio {
+ status = "okay";
+};
+
+&spi {
+ num-cs = <1>;
+
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ uboot: partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ partition@20000 {
+ compatible = "tplink,firmware";
+ label = "firmware";
+ reg = <0x020000 0x3d0000>;
+ };
+
+ art: partition@3f0000 {
+ label = "art";
+ reg = <0x3f0000 0x010000>;
+ read-only;
+ };
+ };
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-handle = <&swphy0>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+ mtd-mac-address-increment = <(-1)>;
+};
+
+&eth1 {
+ status = "okay";
+
+ mtd-mac-address = <&uboot 0x1fc00>;
+
+ pll-data = <0x06000000 0x00000101 0x00001616>;
+
+ gmac-config {
+ device = <&gmac>;
+ switch-phy-swap = <1>;
+ };
+};
+
+&wmac {
+ status = "okay";
+
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/image/tiny-tp-link.mk b/target/linux/ath79/image/tiny-tp-link.mk
index e0c7e283c8..a7a6587889 100644
--- a/target/linux/ath79/image/tiny-tp-link.mk
+++ b/target/linux/ath79/image/tiny-tp-link.mk
@@ -136,6 +136,15 @@ define Device/tplink_tl-wr841-v7
endef
TARGET_DEVICES += tplink_tl-wr841-v7
+define Device/tplink_tl-wr841-v8
+ $(Device/tplink-4mlzma)
+ ATH_SOC := ar9341
+ DEVICE_TITLE := TP-LINK TL-WR841N/ND v8
+ TPLINK_HWID := 0x08410008
+ SUPPORTED_DEVICES += tl-wr841n-v8
+endef
+TARGET_DEVICES += tplink_tl-wr841-v8
+
define Device/tplink_tl-wr841-v9
$(Device/tplink-4mlzma)
ATH_SOC := qca9533