aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-25 16:40:05 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-05 11:09:12 +0100
commit84bd74057f0d2543ddbc7de2351b0a310df329c6 (patch)
tree7c7e358aedf5930eeba27392e3123702503556e5 /target/linux
parentdad48c6438f0a4c42ad34842a88e82280d971d90 (diff)
downloadupstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.gz
upstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.tar.bz2
upstream-84bd74057f0d2543ddbc7de2351b0a310df329c6.zip
build: use mkhash to replace various quirky md5sum/openssl calls
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/image/mt7620.mk6
-rw-r--r--target/linux/ramips/image/mt7621.mk4
2 files changed, 4 insertions, 6 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 95542ae34a..1889bcf708 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -22,11 +22,9 @@ endef
define Build/elecom-header
cp $@ $(KDIR)/v_0.0.0.bin
( \
- $(STAGING_DIR_HOST)/bin/md5sum $(KDIR)/v_0.0.0.bin | \
- sed 's/ .*//' && \
+ mkhash md5 $(KDIR)/v_0.0.0.bin && \
echo 458 \
- ) | $(STAGING_DIR_HOST)/bin/md5sum | \
- sed 's/ .*//' > $(KDIR)/v_0.0.0.md5
+ ) | mkhash md5 > $(KDIR)/v_0.0.0.md5
$(STAGING_DIR_HOST)/bin/tar -cf $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 6d8551104c..6d9a7273d4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -8,13 +8,13 @@ define Build/ubnt-erx-factory-image
$(TAR) -cf $(1) --transform='s/^.*/compat/' $(1).compat; \
\
$(TAR) -rf $(1) --transform='s/^.*/vmlinux.tmp/' $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE); \
- md5sum --binary $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) | awk '{print $$1}'> $(1).md5; \
+ mkhash md5 $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) > $(1).md5; \
$(TAR) -rf $(1) --transform='s/^.*/vmlinux.tmp.md5/' $(1).md5; \
\
echo "dummy" > $(1).rootfs; \
$(TAR) -rf $(1) --transform='s/^.*/squashfs.tmp/' $(1).rootfs; \
\
- md5sum --binary $(1).rootfs | awk '{print $$1}'> $(1).md5; \
+ mkhash md5 $(1).rootfs > $(1).md5; \
$(TAR) -rf $(1) --transform='s/^.*/squashfs.tmp.md5/' $(1).md5; \
\
echo '$(BOARD) $(VERSION_CODE) $(VERSION_NUMBER)' > $(1).version; \