aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-08 14:02:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-08 14:02:50 +0000
commit7b01a650f8ad8d22c360d359432ffe5365bbee4f (patch)
tree837dcbe2051f18cbd12bbe1ca59b9644911ac168 /target/linux
parent293b82501c4f48aa38bf79081f7c11333f234796 (diff)
downloadupstream-7b01a650f8ad8d22c360d359432ffe5365bbee4f.tar.gz
upstream-7b01a650f8ad8d22c360d359432ffe5365bbee4f.tar.bz2
upstream-7b01a650f8ad8d22c360d359432ffe5365bbee4f.zip
ar71xx: allow mktplinkfw calls from the new image code to fail (because of oversized images)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45646
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 00d61ba113..d6e6285c74 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -51,15 +51,14 @@ endef
# -s strip padding from end of the image
# -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
define Build/mktplinkfw
- $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
-k $(word 1,$^) \
-r $@ \
-o $@.new \
-j -X 0x40000 \
-a $(call rootfs_align,$(FILESYSTEM)) \
- $(if $(findstring sysupgrade,$1),-s)
- @mv $@.new $@
+ $(if $(findstring sysupgrade,$1),-s) && mv $@.new $@ || rm -f $@
endef
# -c combined image