aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:54 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-25 20:08:54 +0000
commit78ee7e532ba2183f7f4747a081b9f3ca8ea618f6 (patch)
tree5c3b3540e7d77249c656a87a39a3c4ac1d1d4d38 /target/linux
parent9aeccfeb090f982ee146b637bed0f68c217998bf (diff)
downloadupstream-78ee7e532ba2183f7f4747a081b9f3ca8ea618f6.tar.gz
upstream-78ee7e532ba2183f7f4747a081b9f3ca8ea618f6.tar.bz2
upstream-78ee7e532ba2183f7f4747a081b9f3ca8ea618f6.zip
ar71x: Added support for TP-Link TL-WR841N v11 to 15.05
This patch adds support for the TP-Link TL-WR841N to OpenWrt Chaos Calmer 15.05. Confirmed working [1] and [2]. Signed-off by Stijn Segers <francesco.borromini@inventati.org> [1] https://forum.openwrt.org/viewtopic.php?id=63657 [2] https://forum.openwrt.org/viewtopic.php?id=61309 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49228 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 486ec3af0f..85a18575cc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -576,6 +576,13 @@ define Device/tl-wr841-v10
TPLINK_HWID := 0x08410010
endef
+define Device/tl-wr841-v11
+ $(Device/tplink-4mlzma)
+ BOARDNAME := TL-WR841N-v9
+ DEVICE_PROFILE := TLWR841
+ TPLINK_HWID := 0x08410011
+endef
+
define Device/tl-wr842n-v2
$(Device/tplink-8mlzma)
BOARDNAME := TL-WR842N-v2
@@ -596,7 +603,7 @@ define Device/tl-wr847n-v8
DEVICE_PROFILE := TLWR841
TPLINK_HWID := 0x08470008
endef
-TARGET_DEVICES += tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841-v8 tl-wr841-v9 tl-wr841-v10 tl-wr841-v11 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
define Device/tl-wr941nd-v5
$(Device/tplink-4mlzma)