aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-03 01:22:09 +0000
committerTim Yardley <lst@openwrt.org>2007-03-03 01:22:09 +0000
commit747e57ffe2dc0399886ae17e7476a9baaf8ebeb2 (patch)
treed21d0482c1ff930d7ac9e3d42593c3f80cdedf9d /target/linux
parent066a009c348602f578bbc37f6b83490b4930d679 (diff)
downloadupstream-747e57ffe2dc0399886ae17e7476a9baaf8ebeb2.tar.gz
upstream-747e57ffe2dc0399886ae17e7476a9baaf8ebeb2.tar.bz2
upstream-747e57ffe2dc0399886ae17e7476a9baaf8ebeb2.zip
make the rest of the structure for the targets that dont have profiles yet
SVN-Revision: 6475
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/aruba-2.6/Makefile3
-rw-r--r--target/linux/atheros-2.6/Makefile3
-rw-r--r--target/linux/brcm47xx-2.6/Makefile3
-rw-r--r--target/linux/ixp4xx-2.6/Makefile4
-rw-r--r--target/linux/magicbox-2.6/Makefile4
-rw-r--r--target/linux/pxa-2.6/Makefile3
-rw-r--r--target/linux/rb532-2.6/Makefile4
-rw-r--r--target/linux/sibyte-2.6/Makefile4
-rw-r--r--target/linux/uml-2.6/Makefile4
-rw-r--r--target/linux/x86-2.6/Makefile3
10 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/aruba-2.6/Makefile b/target/linux/aruba-2.6/Makefile
index 5d3e19ea2f..c53964da8a 100644
--- a/target/linux/aruba-2.6/Makefile
+++ b/target/linux/aruba-2.6/Makefile
@@ -18,4 +18,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-madwifi
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/atheros-2.6/Makefile b/target/linux/atheros-2.6/Makefile
index 5404902f37..1700dec8c6 100644
--- a/target/linux/atheros-2.6/Makefile
+++ b/target/linux/atheros-2.6/Makefile
@@ -18,4 +18,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-madwifi
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/brcm47xx-2.6/Makefile b/target/linux/brcm47xx-2.6/Makefile
index ca7fd5d2d1..ab79d82908 100644
--- a/target/linux/brcm47xx-2.6/Makefile
+++ b/target/linux/brcm47xx-2.6/Makefile
@@ -19,4 +19,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
# DEFAULT_PACKAGES += kmod-switch
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/ixp4xx-2.6/Makefile b/target/linux/ixp4xx-2.6/Makefile
index 352671ee69..5eea6d6258 100644
--- a/target/linux/ixp4xx-2.6/Makefile
+++ b/target/linux/ixp4xx-2.6/Makefile
@@ -15,4 +15,8 @@ define Target/Description
endef
include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/magicbox-2.6/Makefile b/target/linux/magicbox-2.6/Makefile
index b829965a50..20325a8fa6 100644
--- a/target/linux/magicbox-2.6/Makefile
+++ b/target/linux/magicbox-2.6/Makefile
@@ -12,4 +12,8 @@ BOARDNAME:=Magicbox
FEATURES:=jffs2
include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/pxa-2.6/Makefile b/target/linux/pxa-2.6/Makefile
index 94e9601b92..76ca28e37c 100644
--- a/target/linux/pxa-2.6/Makefile
+++ b/target/linux/pxa-2.6/Makefile
@@ -17,4 +17,7 @@ endef
include $(INCLUDE_DIR)/kernel-build.mk
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/rb532-2.6/Makefile b/target/linux/rb532-2.6/Makefile
index 6ec9bdcd38..27569a35db 100644
--- a/target/linux/rb532-2.6/Makefile
+++ b/target/linux/rb532-2.6/Makefile
@@ -12,4 +12,8 @@ BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2
include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/sibyte-2.6/Makefile b/target/linux/sibyte-2.6/Makefile
index 364d116d4d..28b3302750 100644
--- a/target/linux/sibyte-2.6/Makefile
+++ b/target/linux/sibyte-2.6/Makefile
@@ -12,4 +12,8 @@ BOARDNAME:=SiByte MIPS
FEATURES:=broken
include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))
diff --git a/target/linux/uml-2.6/Makefile b/target/linux/uml-2.6/Makefile
index 25624108ab..089ef58581 100644
--- a/target/linux/uml-2.6/Makefile
+++ b/target/linux/uml-2.6/Makefile
@@ -24,6 +24,10 @@ FEATURES:=broken
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
endif
$(eval $(call BuildKernel))
diff --git a/target/linux/x86-2.6/Makefile b/target/linux/x86-2.6/Makefile
index 2b8e497c90..0053396891 100644
--- a/target/linux/x86-2.6/Makefile
+++ b/target/linux/x86-2.6/Makefile
@@ -14,5 +14,8 @@ FEATURES:=squashfs jffs2 ext2
include $(INCLUDE_DIR)/kernel-build.mk
DEFAULT_PACKAGES += kmod-natsemi
+# include the profiles
+-include profiles/*.mk
+
$(eval $(call BuildKernel))