aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-13 04:19:32 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-13 14:05:00 +0100
commit6410c30dc7cefdf06dca1e09d1c337138aa4abea (patch)
tree25ead09721a462cb6c9b9eb917b94b5dac95d6c2 /target/linux
parentb9f4f1f97aeeec65a872c4c5b1a0528a69d16d7b (diff)
downloadupstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.tar.gz
upstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.tar.bz2
upstream-6410c30dc7cefdf06dca1e09d1c337138aa4abea.zip
ramips: add support for TOTOLINK A3
TOTOLINK A3 is a clone of ipTIME A3. The only difference is the model name. Specifications: - SoC: MT7628AN - RAM: DDR2 64MB - Flash: SPI NOR 8MB - WiFi: - 2.4GHz: SoC internal - 5GHz: MT7612EN - Ethernet: 3x 10/100Mbps - Switch: SoC internal Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Tested on device by JasonHCH <hsuan670629@gmail.com> Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/ramips/dts/mt7628an_totolink_a3.dts36
-rw-r--r--target/linux/ramips/image/mt76x8.mk9
-rwxr-xr-xtarget/linux/ramips/mt76x8/base-files/etc/board.d/02_network6
3 files changed, 49 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/mt7628an_totolink_a3.dts b/target/linux/ramips/dts/mt7628an_totolink_a3.dts
new file mode 100644
index 0000000000..87dd8559b7
--- /dev/null
+++ b/target/linux/ramips/dts/mt7628an_totolink_a3.dts
@@ -0,0 +1,36 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an_iptime.dtsi"
+
+/ {
+ compatible = "totolink,a3", "mediatek,mt7628an-soc";
+ model = "TOTOLINK A3";
+
+ aliases {
+ led-boot = &led_cpu;
+ led-failsafe = &led_cpu;
+ led-running = &led_cpu;
+ led-upgrade = &led_cpu;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_cpu: cpu {
+ label = "a3:blue:cpu";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "a3:blue:wlan";
+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+ };
+};
+
+&esw {
+ mediatek,portmap = <0x3e>;
+ mediatek,portdisable = <0x32>;
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index faa2ca1c5a..51f630f42a 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -229,6 +229,15 @@ define Device/tama_w06
endef
TARGET_DEVICES += tama_w06
+define Device/totolink_a3
+ IMAGE_SIZE := 7936k
+ UIMAGE_NAME := za3
+ DEVICE_VENDOR := TOTOLINK
+ DEVICE_MODEL := A3
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += totolink_a3
+
define Device/totolink_lr1200
IMAGE_SIZE := 7872k
DEVICE_VENDOR := TOTOLINK
diff --git a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
index 913a0817dc..5230717506 100755
--- a/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt76x8/base-files/etc/board.d/02_network
@@ -72,7 +72,8 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "4:wan" "6@eth0"
;;
- iptime,a3)
+ iptime,a3|\
+ totolink,a3)
ucidef_add_switch "switch0" \
"2:lan:2" "3:lan:1" "0:wan" "6@eth0"
;;
@@ -166,7 +167,8 @@ ramips_setup_macs()
wan_mac=$(macaddr_add "$lan_mac" 1)
;;
iptime,a3|\
- iptime,a604m)
+ iptime,a604m|\
+ totolink,a3)
wan_mac=$(mtd_get_mac_binary u-boot 0x1fc40)
;;
mediatek,linkit-smart-7688|\