aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>2018-01-09 14:25:53 +0300
committerMathias Kresin <dev@kresin.me>2018-01-15 21:45:43 +0100
commit5bdd238b634a34b038fbea9046893de29a77c000 (patch)
treebe539d819e8fc80905b6574132ceebd081b9fb56 /target/linux
parentff1e89553078cb1f8851276537d1267930d740df (diff)
downloadupstream-5bdd238b634a34b038fbea9046893de29a77c000.tar.gz
upstream-5bdd238b634a34b038fbea9046893de29a77c000.tar.bz2
upstream-5bdd238b634a34b038fbea9046893de29a77c000.zip
ramips: add support for TP-Link Archer C20 v4
TP-Link Archer C20 v4 is a router with 5-port FE switch and non-detachable antennas. It's based on MediaTek MT7628N+MT7610EN. Specification: - MediaTek MT7628N/N (580 Mhz) - 64 MB of RAM - 8 MB of FLASH - 2T2R 2.4 GHz and 1T1R 5 GHz - 5x 10/100 Mbps Ethernet - 3x external, non-detachable antennas - UART (J1) header on PCB (115200 8n1) - 7x LED (GPIO-controlled*), 2x button, power input switch * WAN LED in this devices is a dual-color, dual-leads type which isn't (fully) supported by gpio-leds driver. This type of LED requires both GPIOs state change at the same time to select color or turn it off. For now, we support/use only the green part of the LED. * MT7610EN ac chip isn't not supported by LEDE. Therefore 5Ghz won't work. Flash instruction: The only way to flash LEDE image in ArcherC20v4 is to use tftp recovery mode in U-Boot: 1. Configure PC with static IP 192.168.0.66/24 and tftp server. 2. Rename "openwrt-ramips-mt7628-ArcherC20v4-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory. 3. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file. 4. Router will download file from server, write it to flash and reboot. Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds5
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ArcherC20v4.dts170
-rw-r--r--target/linux/ramips/image/mt76x8.mk13
6 files changed, 191 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 37393eeb27..0b0feb4156 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -388,6 +388,11 @@ tplink,c20-v1)
set_usb_led "$boardname:blue:usb"
ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:blue:wlan2g" "wlan0"
;;
+tplink,c20-v4)
+ ucidef_set_led_switch "lan" "lan" "$boardname:green:lan" "switch0" "0x1e"
+ ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
+ ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:green:wlan2g" "wlan0"
+ ;;
tplink,tl-mr3420-v5)
set_usb_led "$boardname:green:usb"
set_wifi_led "$boardname:green:wlan"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index a90fe96f91..7deebbcef0 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -173,6 +173,7 @@ ramips_setup_interfaces()
mzk-wdpr|\
rb750gr3|\
rt-n14u|\
+ tplink,c20-v4|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index df9858cb32..cf37fcf487 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -38,6 +38,7 @@ get_status_led() {
nbg-419n2|\
pwh2004|\
r6220|\
+ tplink,c20-v4|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index 71ad0c1b83..bce49a61d7 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -241,6 +241,7 @@ platform_check_image() {
c50|\
mr200|\
tplink,c20-v1|\
+ tplink,c20-v4|\
tplink,tl-mr3420-v5|\
tl-wr840n-v4|\
tl-wr840n-v5|\
diff --git a/target/linux/ramips/dts/ArcherC20v4.dts b/target/linux/ramips/dts/ArcherC20v4.dts
new file mode 100644
index 0000000000..be0c21a9a9
--- /dev/null
+++ b/target/linux/ramips/dts/ArcherC20v4.dts
@@ -0,0 +1,170 @@
+/dts-v1/;
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+ compatible = "tplink,c20-v4", "mediatek,mt7628an-soc";
+ model = "TP-Link Archer C20 v4";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ lan {
+ label = "c20-v4:green:lan";
+ gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+ };
+
+ power {
+ label = "c20-v4:green:power";
+ gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "c20-v4:green:wan";
+ gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wan_orange {
+ label = "c20-v4:orange:wan";
+ gpios = <&gpio0 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan5g {
+ label = "c20-v4:green:wlan5g";
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan2g {
+ label = "c20-v4:green:wlan2g";
+ gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "c20-v4:green:wps";
+ gpios = <&gpio1 9 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ rfkill {
+ label = "rfkill";
+ gpios = <&gpio1 5 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RFKILL>;
+ };
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x4000000>;
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+ m25p,chunked-io = <32>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x20000>;
+ read-only;
+ };
+
+ partition@20000 {
+ label = "firmware";
+ reg = <0x20000 0x7a0000>;
+ };
+
+ partition@7c0000 {
+ label = "config";
+ reg = <0x7c0000 0x10000>;
+ read-only;
+ };
+
+ rom: partition@7d0000 {
+ label = "rom";
+ reg = <0x7d0000 0x10000>;
+ read-only;
+ };
+
+ partition@7e0000 {
+ label = "romfile";
+ reg = <0x7e0000 0x10000>;
+ read-only;
+ };
+
+ radio: partition@7f0000 {
+ label = "radio";
+ reg = <0x7f0000 0x10000>;
+ read-only;
+ };
+ };
+};
+
+&ehci {
+ status = "disabled";
+};
+
+&ohci {
+ status = "disabled";
+};
+
+&wmac {
+ status = "okay";
+ mediatek,mtd-eeprom = <&radio 0x0>;
+ mtd-mac-address = <&rom 0xf100>;
+ mtd-mac-address-increment = <(-2)>;
+};
+
+&ethernet {
+ mtd-mac-address = <&rom 0xf100>;
+ mediatek,portmap = "wllll";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2s", "refclk", "p0led_an", "p1led_an", "p2led_an", "p3led_an", "p4led_an", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+
+ pcie-bridge {
+ mt76@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ device_type = "pci";
+ mediatek,mtd-eeprom = <&radio 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ mtd-mac-address = <&rom 0xf100>;
+ mtd-mac-address-increment = <(-1)>;
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 8bbbcf6ad9..60864cfed3 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -139,6 +139,19 @@ define Device/tl-wr841n-v13
endef
TARGET_DEVICES += tl-wr841n-v13
+define Device/tplink_c20-v4
+ $(Device/tplink)
+ DTS := ArcherC20v4
+ IMAGE_SIZE := 7808k
+ DEVICE_TITLE := TP-Link ArcherC20 v4
+ TPLINK_FLASHLAYOUT := 8Mmtk
+ TPLINK_HWID := 0xc200004
+ TPLINK_HWREV := 0x1
+ TPLINK_HWREVADD := 0x4
+ TPLINK_HVERSION := 3
+endef
+TARGET_DEVICES += tplink_c20-v4
+
define Device/tplink_tl-mr3420-v5
$(Device/tplink)
DTS := TL-MR3420V5